Anycubice Kobra Max config file

Great news for Kobra Max users ! :slight_smile:
I’m ready with the printer.cfg for it :wink:
Find attached the printer.cfg, let me know if it’s ok
printer.cfg (3.2 KB)

There is a great difference between the Kobra and Kobra Max, Kobra is using sensorless homing and Kobra Max the mechanical switches.

I’m happy with this config, now let’s print :slight_smile:

3 Likes

I received a Sonic Pad for Christmas and modded my config a little bit for the Pad, don’t forget to adapt rotation_distance for stepper_e (I’m using Micro Swiss extruder in place off stock).
Also the PID, Z_OFFSET, Bed_MESH and INPU_SHAPER values are calibrated for my printer, so has to be done on each printer ! Enjoy ! :slight_smile:
printer.cfg (6.8 KB)

1 Like

That’s great! Thanks for your work. I’d like to know how did you manage to compile the firmware for the Kobra Max. Actually, if you want to share your .bin would be great! Thanks a lot.

You can download the bin file from here Release per-merge-testing · SteveGotthardt/klipper · GitHub in the assets. :wink:

1 Like

It worked like a charm! Thank you (:

1 Like

i have a question if i change the file values ​​in x and z would it work for kobra plus or would i have to change some other parameters

Did you have to re solder anything? If so what did you have to do?

Yes, you have to move R65 to R66 (jumper).
image

Hello #Crenwick35 , could you possibly answer two or three questions for me? background: I have a Kopra plus and the Sonic Pad. (but not working yet) to the questions: A.) how do I get it always flashed immediately, it doesn’t transfer anything to me. B ) I can take over your cfg file with the corresponding print bed dimensions. C.) do you have to use the same jumper for the Kobra plus as for the Max? Many thanks for the answer in advance +Digedi+

Hello,
Well from what I see (didn’t have a plus).
A : To flash the klipper FW you need first to change R65 > R66 , then flash the firmware.bin (should beep 4 times quick after flashing and stock display stops on splash screen, no control anymore) I removed the stock display because it’s disabled in Klipper.
B: I think you can take over my config file (just adapt the bed size and middle distance in probe section). And of course Z adjust / Bedmesh and PID tuning.
C:Yes
Good work :wink:

1 Like

Hi, Crenwick35 thank you very much for your answer to my questions, super nice of you. Now I have an information marathon in front of you :slight_smile: because I’m not sure if I’m following the correct order or complied with it: could you briefly write me in a few sentences what exactly I have to do or in what order, I have the feeling that I have something forget. I know I can rely on you so here in advance thank you very much for the future information (digedi) OBER maybe you also know a good tutorial video or a described manual that is better than the one from the creative pad (since it is already designed for “Ender” printers.

because this message comes from the printer after I loaded the cfg file…

"Error message

Printer is not ready The klippy host software is attempting to connect. Please retry in a few moments."

When that message comes up, you need to wait anywhere from two to five minutes for everything to reset and restart.

It can be a long wait, but after a bit it should attempt to restart on its own.

Let us know if that’s not happening.

okay thanks for the message, unfortunately it’s not like that, even after 10 minutes nothing happens and he keeps wanting the cfg file loaded…:confused:

But I see it correctly? that the creative pad should actually install the Klipper software on my Kobra automatic or i must to flash the Klipper software by myself?

What happens if you click on “RESTART_FIRMWARE” or enter it into the console?

It may come back with you waiting but after a couple of minutes or so, it should be coming up (or giving you a more complete error message).

wow thanks for the quick answer👌 I found it out now… now both Pad+Kobra are communicating, but that will now be the problem of the jumper (which I haven’t resoldered yet because I wanted to try it first) because the Sonic Pad controls it However, Cobra displays an error when it ramps up the Z axis.

hey #mykeprredko maybe you have an idea how to do it without resoldering… simply that he can swap the axes in the software…:wink:

I’m glad that they’re communicating.

I’m not familiar with the boards and I’d always recommend to power down and disconnecting before attempting to do any soldering.

@Crenwick35 do you have any comments for @Digedi ?

hey, a.). The soldering is not a problem for me but I would like to avoid it.

b.) @both->> that he now gets out with an error when it’s moving the Z-axis is that because of the jumper? or at the cfg file.

Soldering here is mandatory, it’s due to UART communication.
No other solution known