Can't connect BTT PI to CR200b motherboard through uart

Basic Information:

Printer Model: Creality CR200-B
MCU / Printerboard: Creality V4.2.5, BTT PI 1.2

I already flashed printer mother board with klipper compiled for serial (on USART1 PA10/PA9),
Changed console=display to console=serial in /boot/BoardEnv.txt .
Changed [mcu] serial: /dev/ttyS0 also tried with /dev/ttyAMA0
In printer cfg,
Connected pins 3, 4 of diplay port to rx and tx gpio pins,
Checked continuity of this pins to STM32 PA10/9 pins

Rechecked everything for many times, still nothing happens, getting can’t connect to Klipper error in mainsail.
It worked fine through usb, but i intending to put pi inside printer chasis, so connecting through usb would require drilling hole, and sticking usb cable outside.

I see
mcu ‘mcu’: Unable to open serial port: [Errno 2] could not open port /dev/serial/by-id/usb-1a86_USB_Serial-if00-port0: [Errno 2] No such file or directory: ‘/dev/serial/by-id/usb-1a86_USB_Serial-if00-port0’
In klipper log, does that mean PI still trying to connect through USB ?

What else can i try ?

klippy (4).log (209.8 KB)

I’m not able to add more than 1 attachemnt per reply, so for now will add only printer.cfg, please ask, if other files or photos would be helpful.
printer (1).cfg (6.0 KB)

Just figured, i had been overriding mcu cobfig in printer cfg all that time. Delering second entry fixed the problem

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.