Flashing Klipper friendly bootloader on BTT SKR Mini E3 v2

I was able to fix this board with STlink erasing the chip and installing the original FW from GitHub - GadgetAngel/BTT_SKR_13_14_14T_SD-DFU-Bootloader: This is a repository of BIGTREETECH bootloaders. The originals are stored under the bootloader_bin/backed_up_original_bootloaders/ directory. This repository also has a bootloader for the SKR E3 TURBO to fix the high pitch sound coming out of the CR10_STOCKDISPLAY it is located on the bootloder_bin/compiled_bootloader_bin/ directory. and then used the sdcard to load the FW from following this blog.

Thank you for all the help for my stupid mistake.

Glad to hear you got it fixed! Did you ever try the pin shorting or just went straight to STlink?

Yes Peter I tried short the pins that did not work,

So I purchased the STlink and was able to use SWD interface to erase the chip and then flashed the orginal FW with STlink.

I also ran the old FW with the Sdcard to see if it worked correctly and it did then I flashed the deployer.bin and it work like a charm.

Not sure but you might want to stress the !PA14 in bold to make sure people do not do what I did most people would not be able to see success.

It took me 6 hrs it did not put the stlink utility in the folder in the start menu so I had to go find it and you have to erase because programing the old firmware with out an erase did not work.

So can I use this with UART to the SKR Mini E3 V2?

The reason is I am out of USB ports I ambuilding a V0.2r1
USB webcam
USB for U2C canbus
USB Klipper expander
USB for V0 Display

So kind of need to use UART for the Pi to the board.

I understand the firmware change for the SKR board I need to change just want to make sure it will still function with flashing from the pi that way.

Just be aware that excessive USB usage can create issues. Especially webcams.

Well all but the webcam have there own MCU’s so I am not super concerned about USB usage. I just do not want to lose the ability of upgrading of my controller through the pi and have to use an sdcard again.

This is a bit surprising to me since the manual jumper would physically result in the same state as the !PA14 setting at boot. Unless I am missing something, which is totally possible.

It should theoretically work, but I cannot vouch for how well nor how to do it. Katapult and Klipper both support serial comms. But you would need to confirm the availability of suitable pins and how to wire it all up. Of course you would then need to flash Katapult bootloader configured for serial instead of USB, followed by Klipper configured for serial. Etc.

I will add an emphasized note to the first post, thanks.

hello, I followed a different guide when flashing klipper, it had me use different proccesor model and didnt have me select the GPIO pins…well i tried flashing it and the screen on my ender 3 was blue instead of showing “marlin” and it has remained that way, octoprint cant detect my printer anymore and i dont think my board shows up when i use lsusb command. also i retried following this guide and nothing has changed, seems to be stuck in this state. rapidly clicking reset doesnt make my status led flash at all either. please help, i had this happen the first time i tried flashing klipper then i got a new motherboard and the same thing is happening.

Hi, it’s unfortunately really hard to understand what you may have done from your description. Also I am assuming that you have the SKR Mini E3 v2 board on your Ender.

If you only tried flashing Klipper, then your bootloader should be intact and you should be able to re-flash whatever firmware you’d like using an image on the SD card. On the other hand, if you flashed a new bootloader that was not correctly configured, then you will need access to STlink in order to flash correct bootloader image.

Considering that you started from a different guide and need more general help, your request should probably be moved into it’s own thread.