Can't get skr e3 v3 bootloader working

Basic Information:

Printer Model: Ender 5 pro
MCU / Printerboard:skr e3 v3
Host / SBC

Describe your issue:

Hi all,

I’m trying to flash klipper on my BTT SKR E3 V3.0. I already have klipper on but trying to update. I followed the instrucitons from but when I try the I get a failure.

I tried
./scripts/ /dev/ttyAMA0 btt-skr-mini-e3-v3
./scripts/ /dev/serial/by-id/usb-Klipper_stm32g0b1xx_26000B001450415833323520-if00 btt-skr-mini-e3-v3
./scripts/ /dev/ttyACM0 btt-skr-mini-e3-v3

All give me
Flashing /home/ggenovez/klipper/out/klipper.bin to /dev/ttyAMA0
Checking FatFS CFFI Build…
Connecting to MCU…

SD Card Flash Error: Unable to connect to MCU
Traceback (most recent call last):
File “/home/g/klipper/scripts/spi_flash/”, line 1647, in main
File “/home/gklipper/scripts/spi_flash/”, line 1584, in run
File “/home/g/klipper/scripts/spi_flash/”, line 1570, in run_reactor_task
File “/home/g/klipper/klippy/”, line 292, in run
File “/home/g/klipper/klippy/”, line 340, in _dispatch_loop
timeout = self._check_timers(eventtime, busy)
File “/home/gklipper/klippy/”, line 158, in _check_timers
t.waketime = waketime = t.callback(eventtime)
File “/home/g/klipper/klippy/”, line 48, in invoke
res = self.callback(eventtime)
File “/home/g/klipper/scripts/spi_flash/”, line 1518, in run_reset_upload
File “/home/g/klipper/scripts/spi_flash/”, line 1202, in connect
raise SPIFlashError(“Unable to connect to MCU”)
SPIFlashError: Unable to connect to MCU

Any help would be greatly appreciated.


Ok. I’m an idiot. I forgot to stop the service. once I did it connected but I might have bricked the BTT

I ran the script and got

Checking FatFS CFFI Build…
Connecting to MCU…Connected
Checking Current MCU Configuration…Done
MCU needs restart: is_config=1, is_shutdown=1
Attempting MCU Reset…Done
Waiting for device to reconnect…Done
Connecting to MCU…Connected
Initializing SD Card and Mounting file system…

SD Card Information:
Version: 2.0
Write Protected: False
Sectors: 15761408
manufacturer_id: 255
product_name: SD08G
product_revision: 2.32
serial_number: 00000083
manufacturing_date: 12/2019
capacity: 7.5 GiB
fs_type: FAT32
volume_label: b’’
volume_serial: 405344664
Uploading Klipper Firmware to SD Card…Done
Validating Upload…Done
Firmware Upload Complete: firmware.bin, Size: 26120, Checksum (SHA1): F4C460613E42BC920347FC5A867FBB18CE80F0CD
Attempting MCU Reset…Done
Waiting for device to reconnect…Error

Now it won’t show on my RPI. I put the firmware.bin on the sd card and rebooted. nothing.

I don’t see it flashing and I don’t see it in my /dev/serial/ folder.

Having one of those nights :frowning:

It is possible that you have not correctly set the parameters during make menuconfig
Strictly follow BIGTREETECH-SKR-mini-E3/firmware/V3.0/Klipper at master · bigtreetech/BIGTREETECH-SKR-mini-E3 · GitHub and make sure it is really a SKR-mini-E3-V3.0

NICE! not only did that work I have a partial working BTT screen

Put the [display] below and now it shows marlin mode and touch mode but doesn’t go further than that.

lcd_type: emulated_st7920
spi_software_miso_pin: PD8 # status led, Virtual MISO
spi_software_mosi_pin: PD6
spi_software_sclk_pin: PB9
en_pin: PB8
encoder_pins: ^PA10, ^PA9
click_pin: ^!PA15

[output_pin beeper]
pin: PB5

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.