Start G-Code & macro help

Basic Information:

Printer Model: Ender 3 V2
MCU / Printerboard: Raspberry Pi 3 B+
klippy (1).zip (493.4 KB)

Fill out above information and in all cases attach your klippy.log file. Pasting your printer.cfg is not needed

I need help with start macro & a z-hop homing macro. I am pulling my hair out at this stage & I have tried so many things I don’t know where to start anymore.

My start macro is overriding the slicer bed & nozzle temp with the values in the Macro. so I either have to change thoes temps before printing or tune the temperatures back to required after the print has started. (This sucks if you forget) as I am constantly changing PLA to PETG.

Also I want to have a z-hop before homing starts. This is incase a print starts & the nozzle is too low. I want to rais the nozzle 5mm before the X&Y home to prevent scratching the bed or knocking the clips off that hold the glass bed in place.
I have read the macro tutorial here & while it is great I still cannot get my head around how to fix these 2 “simple” macros.

So I got the FORCE_MOVE macro working. I added the following to priter.cfg:
enable_force_move: True
This is my macro I used:
[gcode_macro FORCE_MOVE_UP_HOME]
description: Force move Z up 5mm then home all
SAVE_GCODE_STATE NAME=force_move_up_then_home
G28 #Home All Axes
RESTORE_GCODE_STATE NAME=force_move_up_then_home

This isn’t really the purpose of force move. If you want to move z up before homing, a better option is to use a homing override.