Can't find usb id for BTT CB1+M8p

Big Tree Tech Manta M8P and CB1

I’m trying to SSH and use ‘ls /dev/serial/by-id/’ and it just responds ‘no such file or directory’. I don’t know how to find the USB ID to put into Klipper.

Mainsail works, SSH works, WinSCP works, the board comes up with ‘lsusb’ command. What do I do?

Normally, we’d just tell you but since the start of the new year our psychic powers have been a bit spotty.

So, we’ll have to go the old fashioned way and have you detail the process you’re using to set up your printer along with all of the responses that you get that seem noteworthy. A klippy.log, like you were asked for when you started this thread would also be helpful.

With that information, we should be have some ideas as to where the problems are and how you can move foreward.

I downloaded the full version of debian with klipper for the CB1 (from BTT Github). I made a config and flashed the Manta M8P with an SD card. Mainsail works, SSH works, WinSCP works. I can’t use ‘ls /dev/serial/by-id/’ and there is no ‘serial’ file in the file directory. This printer has been working for months but recently it stopped connecting to my wifi on power up. So, like a genius, I installed a whole new version of the CB1-specific debian and now it doesn’t have a serial folder anymore for some reason. Should I try installing the generic Mainsail OS in the Pi imager or is there something else I should try?

I hope that was enough information this time

And my Klippy.log file as well
klippy (2).log (50.4 KB)

Looking at your klippy.log, it looks like you’ve left out a number of things and there still is a lot of information that you still need to supply. Based on what I’m seeing here, you didn’t keep a backup of your printer.cfg.

What are the parameters that you used in make menuconfig for your Manta M8P? How are you expecting the CB1 to communicate with the Manta M8P?

What are the steps you used when you reimaged the CB1?

Now, looking at you klippy.log, you seem to have tried to connect using:

serial = /dev/ttyS0

Which failed repeatedly.

In the last case, you are tried:

serial = 1d50:614e

Which won’t be interpreted correctly by Klipper.

Now, if you’re connecting the USB to your CB1 on the Manta M8P, you should be have an id like: usb-klipper_stm32g0b1xx_42000E0011504B4633373520-if00 that will stay constant even though you’ve reimaging the CB1.

Do you have a record of this USB ID? What about the printer.cfg you were using previously?

Did you install KIAUH? This is why I asked you to “detail the process” you used as the information you’ve provided here just creates more questions back at you than answers.

Finally, if you install the "generic Mainsail OS in the Pi imager " on the CB1 it will just sit there, maybe an LED will flash but don’t count on anything useful happening. The CB1 needs to have the BTT version of Debian (although I have found some other images that will work on the CB1 by looking around the interwebs) and then have Klipper (and Moonraker and Mainsail) added through KIAUH.

No, I didn’t keep a backup and I’m trying to fix the MCU issue before moving on to that

I copied the settings from a CB1 and M8P guide. The CB1 fits into a dedicated spot on the board and used to work, so it should be able to connect over USB (the USB lines run from the MCU to the CB1/CM4 connectors).

I downloaded the CB1-specific version of Debian from the BTT Git Hub (with Klipper, mainsail, and Moonraker preinstalled). I was just trying things with the MCU address, I don’t know much about this stuff and was quite desperate. I have no record of the USB address or printer.cfg I used previously so that won’t work. I did install KIAUH and checked that everything was installed correctly (it was).

  1. Verify that you have a M8P v1.x and not a v2.x since the flashing procedures are different
  2. Carefully work through Installing Klipper with KIAUH

I have a M8P v1.1

Wait, I do have the USB ID. I commented it out before trying the other thing I did. I uncommented it and removed the other and it still doesn’t connect. and what about the CB1 not having a serial file in its directory?

What happens when you power down the Manta M8P and the CB1 (which I presume is in the slot in the Manta M8P)? NOT RESET, but a power cycle with at least 15 seconds off.

Upon power up, you should SSH into the CB1 and execute:


And list the devices that appear in your reply. I would expect an “OpenMoko” in the list what you get back. Based on what I’m seeing with one of my Manta M8Ps, you should get:

Next, do:

ls /dev/serial/by-id/

and list the response.

In the screen shot above, I’m not getting anything because the Manta M8P is connected to the CB1 via CAN over USB using Katapult.

if you get “No such file or directory”, we’ll look at how you set up your CB1.

I can’t believe it, after booting up this morning and trying that, I got a USB ID. I’m so lost as to why that worked, but it did, thank you.


1 Like

Power cycling solves an amazing number of problems.

Glad you’re back up and working.

1 Like

You can use KIAUH to find the ID it’s in the update menu then I think by memory it’s the bottom option. But I’m glad you got it working.

HI thank you for active support. I just read the thread because i have the same issues after months working before the last klipper update. Could you please tell me what to do because in my case i can´t see after the lsusb command the “OpenMoko”? I appreciate your help
Best regards Peter

What is the process that you’re going through?

Could you please list it in as much detail as possible (ie don’t say, “I’m following this link…”) - I need to know exactly what you have been doing.

Hi first of all i post my setup:
i have a Bigtreetech manta m8p V1.1 with a CB1

  1. I downloaded from the bigtreetech github page the CB1 debian 11 Releases · bigtreetech/CB1 · GitHub → i downloaded the V 2.3.2 → i downloded the 1.02 gb file
  2. i wrote the image with raspberry pi imager
  3. i adjusted the wifi settings on the sd card with miy wifi name &password
  4. i set the jumper to my manta board and powered the board via usb
  5. i configured the motherboard → i sshed with mobaxterm → i was able to login via ssh to my cb1
  6. i compiled the firmware according to the bigtreetech manual
  7. i created the klipper.bin and renamed it before sending to my second sd card to firmware.bin
  8. i depowerd my board and put the sd card with the firmware.bin then i repowered the board the flashed the firmware
  9. i checked if the firmware.bin was renamed to FIRMWARE.CUR → this also worked
  10. After all this succesful steps i was very confidend that all will work fine–> but after entering ls /dev/serial/by-id/* command i got this failure ls: cannot access ‘/dev/serial/by-id/’: No such file or directory and from this point i didn´t have any progress.
    I appreciate if you can help me.
    attached are also my klippy & moonraker.log files if it helps. The usb id was the last working one before my current klipper update.

Best regards PEter

I presume the CB1 is mounted on the Manta M8P?

Also, did you power down and power back up before doing the ls /dev/serial/by-id command?

yes the board is correct mounted to the manta m8p
and i power down and power back up before doing the ls command
klippy(4).log (17.0 KB)
moonraker(2).log (6.4 KB)
attached are my log files

Sorry, where did you get the USB ID usb-Klipper_stm32g0b1xx_26000C0011504B4633373520-if00 that you’re using?

From what you’ve written, it doesn’t sound like ls /dev/serial/by-id/ ever returned a value.

this was my id in my printer.cfg where all worked before i made my last klipper update. Since this last update my mcu is not longer recognized

Can you try to run the command udevadm info --query=all --name=/dev/ttyACM0 (Update the ttyACMO based on the devices attached to your system). The output will give the details of the USB device and what ‘DEVLINKS’ it uses which is also the by-path ID.

Add the path-id to your printer.cfg and your good to go like:

serial: /dev/serial/by-path/platform-fd500000.pcie-pci-0000:01:00.0-usb-0:1.3:1.0