Creality 4.2.7 mainboard bricked?

Basic Information:

Printer Model: Ender 3 V2
MCU / Printerboard: 4.2.7 STM32F103
PC: Intel NUC 8
OS: Debian 12
klippy.log (1.1 MB)

Hi all,

first of all I’d like to appreciate Klipper and all the effort that people put into it. Really nice, can’t wait until I put my hands on input shaping :smile:

Unfortunately though it is the second time that are weird things happening to the printer while using Klipper.

The first time I was using 4.2.2 board (was about 3y old at the time) and it died - can’t flash, serial not detected etc. OK, maybe it was just old. I bought a new board 4.2.7 this time and the problem occurred again, but this time with an awful audible feedback from all 4 steppers.

While cleaning the nozzle after a failed print, suddenly klippy lost connection to MCU (I’ve noticed out of the corner of my eye) and all 4 steppers started buzzing really loud. It seems they are “locked” as it’s impossible to move them. Disconnecting all motors makes it quiet again. I’ve noticed that the MCU and drivers are getting quite hot when the printer just sits there and do nothing.

The board also doesn’t show up in /dev/serial, no dmesg entries either. I’ve tried different PCs, USB ports and cables.

It is also not possible to flash any firmware onto the board. I’ve tried: many different SD cards, formatting (FAT, 4k, disable “Quick Format”, MBR etc - all I could find online), renaming the .bin file, Mriscoc and Creality firmware.

Maybe the boards were faulty and Klipper just surfaced the problem(s), on the other hand I’ve been running Marline based firmware since I’ve started 3D printing (on this very printer) and never seen a problem like this before.

I’ve made a post here, please see the video:

Thanks in advance and have a nice day! :slight_smile:

Anyone has any suggestions?

So the motors are blocking immediately after you power on the printer?

I would suggest a minimum to POST config if this was a PC. Meaning disconnect everything that is not necessary for the printer to power on properly.
This includes all motor cables, probes and fans and stuff.
If possible before turning on the printer check the fans separately on a bench power supply so that you at least can have the fans for the board connected.
Check every cable and connector for damages or maybe some lose wire strains and check the board for some suspicious marks.

With this basic setup try to connect to the printer or check whether you can see the board in Linux.
If this is working you can step by step connect a single component and redo the procedure.

Maybe you should also power drain the board/printer. So disconnect all USB and power cables and turn on the printer. Wait a couple of seconds and turn off again.
This will consume remaining current and emptying capacitors on the board.
Sometimes this will do the trick already.

Good luck!

mcu 'mcu': Unable to open serial port: [Errno 2] could not open port /dev/serial/by-id/usb-1a86_USB_Serial-if00-port0: [Errno 2] No such file or directory: '/dev/serial/by-id/usb-1a86_USB_Serial-if00-port0'

This is your error. In the first place, this is an indication that the board does not correctly announce itself as an USB device on Linux OS level.

Follow the dmesg procedure and attach the output.

Thanks for replies guys.

Meaning disconnect everything that is not necessary for the printer to power on properly.

I’ve tries all the cables one by one leaving my only with + and GND from the the PSU. The same behavior. Also did the capacitor discharge procedure every time.

I took the board outside and visual inspection does not show anything unusual.

If possible before turning on the printer check the fans separately on a bench power supply

Check, all works as intended.

Follow the dmesg procedure and attach the output.

Nothing appears if the cable is plugged in after later than 1-2 seconds after switching the printer on. This appears only when plugging in USB right after hitting the switch on the printer:

[Jan23 20:28] usb 1-2: new full-speed USB device number 5 using xhci_hcd
[  +0.150813] usb 1-2: New USB device found, idVendor=1a86, idProduct=7523, bcdDevice= 2.64
[  +0.000008] usb 1-2: New USB device strings: Mfr=0, Product=2, SerialNumber=0
[  +0.000004] usb 1-2: Product: USB Serial
[  +0.028542] usbcore: registered new interface driver usbserial_generic
[  +0.000010] usbserial: USB Serial support registered for generic
[  +0.001763] usbcore: registered new interface driver ch341
[  +0.000018] usbserial: USB Serial support registered for ch341-uart
[  +0.000018] ch341 1-2:1.0: ch341-uart converter detected
[  +0.000676] usb 1-2: ch341-uart converter now attached to ttyUSB0
[  +1.117594] usb 1-2: USB disconnect, device number 5
[  +0.000353] ch341-uart ttyUSB0: ch341-uart converter now disconnected from ttyUSB0
[  +0.000031] ch341 1-2:1.0: device disconnected

As you can see it disconnects after short while and a bit later goes into the noisy mode again (I can actually hear the stepper drivers doing a whispering constant buzz noise).

brltty package is not installed on the system.

What do you exactly mean with that?
Do you mean the USB connection of the RasPi to the MCU or what?
Or do you connect a PC to the MCU as well or what?

Does the board have a power jumper to select between USB and PSU power supply?

I was referring to dmesg log entries when plugging in the MCU to PC via USB.

Scenario 1:

  1. Plug USB cable to MCU
  2. Power on the printer
  3. The dmesg log entries from my previous post appear

Scenario 2:

  1. Power on the printer
  2. Wait > 1 second
  3. Plug the USB cable to MCU
  4. No dmesg log entries appear at all

I can’t see any jumpers on Creality 4.2.7 board but I’ve tried with another USB cable where I removed the +5V pin from the connector - then nothing at all appears in dmesg no matter if its scenario 1 or 2. Maybe the cable is faulty, not sure.

Sorry, but I fear also your 2nd Creality 4.2.7 mainboard is bricked!

Just have a look at your video

Also read again what @Tacobellcar_ said Reddit - Dive into anything!

I wonder why you bought that piece of sh*t a second time.

I would start with a fresh thread! “Good replacement for Creality 4.2.7 mainboard?”

Good luck, hcet14

Yeah it seems like it. I have ordered BIGTREETECH SKR Mini E3 V3.0. Hope this will be better and not die after several hours…

EDIT: I was also thinking about getting the ST-Link V2 programming dongle. Do you thing that could show some more information about the state of the MCU?

Are you talking about this BIGTREETECH-SKR-mini-E3/hardware/BTT SKR MINI E3 V3.0/Hardware at master · bigtreetech/BIGTREETECH-SKR-mini-E3 · GitHub

I don’t know the board. Made bad experices with BTT SKR 2 GitHub - bigtreetech/SKR-2.

My favorite boards are StepStick boards, but…

My hint would be, read the issues and prs (GitHub - bigtreetech/BIGTREETECH-SKR-mini-E3: BIGTREETECH SKR-mini-E3 motherboard is a ultra-quiet, low-power, high-quality 3D printing machine control board. It is launched by the 3D printing team of Shenzhen BIGTREE technology co., LTD. This board is specially tailored for Ender 3 printer, perfectly replacing the original Ender3 printer motherboard.) before you decide.

Never bad to have it, but don’t buy too cheap. I did :lol:!EUR!1.59!1.35!!!1.69!1.44!%40211b813f17061173427456729e7d66!12000037070214855!sea!DE!0!AB&curPageLogUid=xCpXTvyZALag&utparam-url=scene%3Asearch|query_from%3A
Make sure you buy one with a “real” STM32 and not one with a Geehy MCU!

That is a fine board, what should be wrong with it?
Works fine and is being tortured in my tinker CoreXY.

Many stepper drivers died!

I also made some other modifications.
BIGTREETECH SKR 2-SCH_hcet14_220619.pdf (173.9 KB)

1 Like

Are you talking about this BIGTREETECH-SKR-mini-E3/hardware/BTT SKR MINI E3 V3.0/Hardware at master · bigtreetech/BIGTREETECH-SKR-mini-E3 · GitHub


You had problems with the previous revision - I hope they have corrected the some issues. I don’t want to go through Creality boards again since two have failed already. Also just a new motherboard costs a bit less than half of the used Ender 3 :laughing: I hope the BTT does better job here.

I’ve also seen that they have modular motherboards now, which also sounds nice.

My hint would be, read the issues and prs

Aren’t those mainly for firmware they also make for it? Since I will be using klipper anyway, this doesn’t apply I guess…

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.