E3V2 / 'ls /dev/serial/by-id/*' not working

When I try to do ‘ls /dev/serial/by-id/', pi says "ls: cannot access '/dev/serial/by-id/’: No such file or directory". I tried lots of solutions, but none of them worked for me. What should i do?

Ender3 V2
Raspberry Pi 3B

1 Like

Typically this means your board’s firmware is not correctly working.

  • Not following the instructions in the instructions / cfg
  • Wrong firmware build options during make menuconfig
  • Faulty USB connection

Possible solutions:

[195076.138745] usb 5-1: USB disconnect, device number 12
[195076.630171] usb 5-1: new full-speed USB device number 13 using ohci-platform
[195076.865050] usb 5-1: New USB device found, idVendor=1d50, idProduct=614e, bcdDevice= 1.00
[195076.865061] usb 5-1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[195076.865065] usb 5-1: Product: lpc1769
[195076.865068] usb 5-1: Manufacturer: Klipper
[195076.865071] usb 5-1: SerialNumber: 0C70001625813AAF86E06B5CC32000F5
[195076.867287] cdc_acm 5-1:1.0: ttyACM0: USB ACM device
1 Like

Thanks for your reply!
Although I followed Klipper documentation and remade menuconfig, also using several other usb cables, it was still the same.
Also, there was no lines like yours; instead, like this:

[   17.231491] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[   17.231514] Bluetooth: BNEP filters: protocol multicast
[   17.231533] Bluetooth: BNEP socket layer initialized
[   17.254938] NET: Registered PF_ALG protocol family
[   17.293833] cryptd: max_cpu_qlen set to 1000
[   22.240633] vc4-drm soc:gpu: [drm] Cannot find any crtc or sizes
[   35.039742] cam-dummy-reg: disabling

It’s the same result before removing usb cables.

I think, the usb port of rpi might be broken since there was no change at dmesg. But, I don’t think the port could be broke so easily.

If you followed:

  1. Unplug USB
  2. Re-plug USB
  3. sudo dmesg

and this is the result then you have you have a problem. Your board is not even recognized as USB device by the Linux operating system. Something with respect to USB must show up there or your board plays dead towards the Linux OS on your RPi.
In such cases there is nothing Klipper can do. Even a “bricked” board normally shows up as USB device (unless it is completely burned)

1 Like

Hmm… I see. Let me check this board. Thanks

In my experience, every controller board that uses the horrible ch340 USB chip tends to do these shnanigans.
plug-unplug, wiggling the USB cable at the computer/PI end will eventually work.

Be patient and good luck

Thanks benmed! But I already tried this, and failed…

I just bought another board - SKR mini e3 v3.0.
Thanks for all people who helped me!

Hi I had this same problem with Ender 3v1, but with a Creality V4.2.7 board. I had used octoprint successfully with klipper, and then tried fluiddpi and came to the same problem, I found out my problem:I changed usb cables during the switch and the usb cable is working fine in charging though, so i wonder why. So my fix was changing cables.

I got it to work by using the path instead of the ID. Just use ls /dev/serial/by-path/* and put the outcome in the mcu section after serial.

1 Like

yeah, I had my printer working without updates for a year. yesterday I updated all from OS to FluiddPi to Klipper and after even printed successful 2h print.

After rebooting via printer button (muster switch for pi and printer), I got same error Fluidd could not connect to host (Klipper) - though fluid I edited printer.cfg to the output of ls /dev/serial/by-path/* because by-path was the only file in serial folder.

AND IT WORKS! (Note: sudo dmesg did give me my USB output reading after replugging, so I knew usb was good)

Check Debian 11 (Bullseye) udev bug - No board or serial found