Ls /dev/serial/by-id/* no longer works - WORKAROUND

Basic Information:

Printer Model: Formbot Raptor 2
MCU / Printerboard: Vivedino 1.1 (mega2560 mcu)

Fill out above information and in all cases attach your klippy.log file. Pasting your printer.cfg is not needed
Be sure to check our Knowledge Base and in particular this and this post

Describe your issue:

after a couple of days off, my working klipper installation on pi400 couldnt find the printer.
Command ls /dev/serial/by-id/*
Output ls: cannot access ‘/dev/serial/by-id/*’: No such file or directory.

find a post (E3V2 / 'ls /dev/serial/by-id/*' not working - #11 by HD4K)
that workaround was the solution. I dont know what happens, put here for reference.


Youre fast! the reply cames before my edit
Workaround for reference added to the tittle.
Many thanks for the answer!


I think I’m affected by this bug…

I have tried the solution, but it still doesn’t work.

When editing the file with the sources… is this content correct?

deb bullseye main contrib non-free rpi
# Uncomment line below then 'apt-get update' to enable 'apt-get source'
#deb-src bullseye main contrib non-free rpi
deb bullseye-backports main non-free contrib

I think yes, keys are ok? as per post

Solved… another user pass me a Script that solved de issues in Fluidd


@Peurif care to share the script? :slight_smile: Thx!