Experimental printer setup waiting minutes before printing

Basic Information:

Printer Model: Ender 5
MCU / Printerboard: BTT SKR Pro V1.2
klippy.log: See attached
klippy.log (824.5 KB)

Hi all,

I am trying to build what is called an embedded 3D printer as a part of my masters degree research and and have had great success but I’ve run into a snag. The printer will sit for about 4 minutes after moving to its start position. For my current testing I don’t need either the bed or the extruder to heat up since I am actually only extruding liquids at room temperature. This means a considerable amount of time is spent doing, as far as I can tell, nothing.

I have done a number of things to allow printing at room temperature and avoid errors. I have set the bed heater and extruder min_temp/min_extrude_temp to 0. I have set the target temperature for both in the slicer (Cura) to 20 degrees Celsius. I have used the TEMPERATURE_WAIT command in my START_PRINT macro with a +/- 5 degrees Celsius maximum/minimum on both the extruder and bed sensors to avoid any heating or cooling requirements.

The reasons why I would like to avoid the long waiting time is the fluid tends to ooze, which is not a significant problem when the majority of startup procedure is spent on the G28 command but over much longer periods of time the first few layers are under-extruded. Later on in my testing I would like to use fluids that may cure in about 40 minutes after mixing and would rather not spend 10% of that time sitting essentially idle.

I suspect the simplest solution would possibly be to remove all heating and cooling related commands from my START_PRINT macro but I would like to preserve the ability of the slicer to dictate the temperature. It is very likely advantageous with other fluids to heat them up so they have more desirable properties and this printer may be used by other people in future and would rather not pass on my problems to them.

Why do you have that [start_print] macro at all?

It is for temperature purposes only.

You may check all other macros too for if you really need them.

Actually, I don’t have a [start_print] macro. And I do not need one.

I agree its not really necessary. I’ve also never had a start_print macro with my personal printer and the embedded printer. I only shifted over to it after experiencing some issues trying to get TEMPERATURE_WAIT to work. Its now streamlined things a bit since I only need to edit most of the print parameters in one place than in printer.conf and inside Cura’s machine settings and I don’t need to reslice test files after every edit.

Now all that is in the “Start G-code” section of the Machine Settings in Cura is:
START_PRINT BED_TEMP={material_bed_temperature_layer_0} EXTRUDER_TEMP={material_print_temperature_layer_0, 0}


I believe the above reddit link is what I used for TEMPERATURE_WAIT if anyone is interested

As an update I found my issue. In the very last line of my start_print macro I sent the command G1 Z2 F0.5. Note of course that G-code F related commands are in mm/min, NOT mm/s. This perfectly explains why startup would take 4 minutes.

I’ve now changed it to G1 Z2 F1000. Now this command takes less than a second instead of minutes. Apologies for my mistake here. Consider this issue resolved.

1 Like