Hotend heating issues but only with Klipper

Basic Information:

Printer Model: Ender 5 Pro
MCU / Printerboard: creality 4.2.2 “GD chip”
Host / SBC raspberry pi 5
klippy.log - not available at the moment. will update

Fill out above information and in all cases attach your klippy.log file (use zip to compress it, if too big). Pasting your printer.cfg is not needed
Be sure to check our “Knowledge Base” Category first. Most relevant items, e.g. error messages, are covered there

Describe your issue:

When running Klipper the printer cannot complete a PID tune above 150 deg. Anything above that and it fails. If I try to print it will start as long as my temp isn’t over 200 deg and will run for a little while but then shuts down with the “heater not heating at expected rate” error.

However, if I run marlin, i can PID tune as high as 230 deg and I do not have any errors.

I thought it was faulty temp sensor or heater cartridge at first but since they work with Marlin, I assume is some software issue somewhere.

Anyone else have this issue ?

Thanks,
Brian

Let’s wait for the klippy.log

1 Like

Here is the Klippy Log.

===== Config file =====
[virtual_sdcard]
path = /home/pi/printer_data/gcodes

[display_status]

[pause_resume]

[gcode_macro CANCEL_PRINT]
description = Cancel the actual running print
rename_existing = CANCEL_PRINT_BASE
gcode =
TURN_OFF_HEATERS
CANCEL_PRINT_BASE

[gcode_macro M0]
gcode =
PAUSE

[safe_z_home]
home_xy_position = 125, 125
speed = 250
z_hop = 10.0
z_hop_speed = 100.0

[stepper_x]
step_pin = PC2
dir_pin = PB9
enable_pin = !PC3
microsteps = 16
rotation_distance = 40
endstop_pin = ^PA5
position_endstop = 220
position_max = 220
homing_speed = 50

[stepper_y]
step_pin = PB8
dir_pin = PB7
enable_pin = !PC3
microsteps = 16
rotation_distance = 40
endstop_pin = ^PA6
position_endstop = 220
position_max = 220
homing_speed = 50

[stepper_z]
step_pin = PB6
dir_pin = PB5
enable_pin = !PC3
microsteps = 16
rotation_distance = 4
endstop_pin = ^PA7
position_max = 300
position_min = -2.0
position_endstop = 0.0

[extruder]
max_extrude_only_distance = 100.0
step_pin = PB4
dir_pin = PB3
enable_pin = !PC3
microsteps = 16
rotation_distance = 33.63568
nozzle_diameter = 0.400
filament_diameter = 1.750
heater_pin = PA1
sensor_type = EPCOS 100K B57560G104F
sensor_pin = PC5
control = pid
pid_kp = 29.03
pid_ki = 1.57
pid_kd = 134.12
min_temp = 0
max_temp = 260

[heater_bed]
heater_pin = PA2
sensor_type = EPCOS 100K B57560G104F
sensor_pin = PC4
min_temp = 0
max_temp = 135
control = pid
pid_kp = 75.516
pid_ki = 1.176
pid_kd = 1212.037

[fan]
pin = PA0

[mcu]
serial = /dev/serial/by-id/usb-1a86_USB_Serial-if00-port0
restart_method = command

[printer]
kinematics = cartesian
max_velocity = 400
max_accel = 5000
max_z_velocity = 5
max_z_accel = 100
square_corner_velocity = 5

[bed_screws]
screw1 = 30.5, 37
screw2 = 30.5, 207
screw3 = 204.5, 207
screw4 = 204.5, 37
screw5 = 120, 120

[display]
lcd_type = st7920
cs_pin = PB12
sclk_pin = PB13
sid_pin = PB15
encoder_pins = ^PB14, ^PB10
click_pin = ^!PB2

[input_shaper]
shaper_freq_x = 56.179
shaper_type_x = mzv
shaper_freq_y = 23.148
shaper_type_y = mzv

Loaded MCU ‘mcu’ 106 commands (v0.12.0-143-g01c7befa / gcc: (15:8-2019-q3-1+b1) 8.3.1 20190703 (release) [gcc-8-branch revision 273027] binutils: (2.34-4+rpi1+14) 2.34)
MCU ‘mcu’ config: ADC_MAX=4095 BUS_PINS_i2c1=PB6,PB7 BUS_PINS_i2c1a=PB8,PB9 BUS_PINS_i2c2=PB10,PB11 BUS_PINS_spi1=PA6,PA7,PA5 BUS_PINS_spi1a=PB4,PB5,PB3 BUS_PINS_spi2=PB14,PB15,PB13 BUS_PINS_spi3=PB4,PB5,PB3 CLOCK_FREQ=72000000 MCU=stm32f103xe PWM_MAX=255 RECEIVE_WINDOW=192 RESERVE_PINS_serial=PA10,PA9 SERIAL_BAUD=250000 STATS_SUMSQ_BASE=256 STEPPER_BOTH_EDGE=1
Configured MCU ‘mcu’ (1024 moves)
Args: [‘/home/pi/klipper/klippy/klippy.py’, ‘/home/pi/printer_data/config/printer.cfg’, ‘-I’, ‘/home/pi/printer_data/comms/klippy.serial’, ‘-l’, ‘/home/pi/printer_data/logs/klippy.log’, ‘-a’, ‘/home/pi/printer_data/comms/klippy.sock’]
Git version: ‘v0.12.0-179-g434770ea’
Branch: master
Remote: origin
Tracked URL: GitHub - Klipper3d/klipper: Klipper is a 3d-printer firmware
CPU: 4 core ?
Python: ‘3.11.2 (main, Mar 13 2023, 12:18:29) [GCC 12.2.0]’
webhooks client 140732967740752: {‘program’: ‘Moonraker’, ‘version’: ‘v0.8.0-352-g326d23a’}
=============== Log rollover at Tue May 7 06:42:48 2024 ===============
b’Got EOF when reading from device’
Timeout with MCU ‘mcu’ (eventtime=144773.499562)
Transition to shutdown state: Lost communication with MCU ‘mcu’
Dumping gcode input 0 blocks
Dumping 20 requests for client 140732967740752
Received 102236.499408: b’{“id”: 140732890602448, “method”: “list_endpoints”, “params”: {}}’
Received 102236.499771: b’{“id”: 140732890098000, “method”: “objects/subscribe”, “params”: {“objects”: {“webhooks”: null, “print_stats”: null}, “response_template”: {“method”: “process_status_update”}}}’
Received 102236.749425: b’{“id”: 140733214916176, “method”: “objects/list”, “params”: {}}’
Received 102236.749811: b’{“id”: 140733214916176, “method”: “objects/query”, “params”: {“objects”: {“configfile”: null}}}’
Received 102237.000199: b’{“id”: 140732862877008, “method”: “register_remote_method”, “params”: {“response_template”: {“method”: “shutdown_machine”}, “remote_method”: “shutdown_machine”}}’
Received 102237.000418: b’{“id”: 140733194497296, “method”: “register_remote_method”, “params”: {“response_template”: {“method”: “reboot_machine”}, “remote_method”: “reboot_machine”}}’
Received 102237.000568: b’{“id”: 140732889545872, “method”: “register_remote_method”, “params”: {“response_template”: {“method”: “pause_job_queue”}, “remote_method”: “pause_job_queue”}}’
Received 102237.000702: b’{“id”: 140732889545872, “method”: “register_remote_method”, “params”: {“response_template”: {“method”: “start_job_queue”}, “remote_method”: “start_job_queue”}}’
Received 102237.001335: b’{“id”: 140733194494672, “method”: “objects/query”, “params”: {“objects”: {“heaters”: null}}}’
Received 102237.001391: b’{“id”: 140733194492752, “method”: “objects/query”, “params”: {“objects”: {“heaters”: null}}}’
Received 102237.250964: b’{“id”: 140733194501264, “method”: “objects/subscribe”, “params”: {“objects”: {“webhooks”: null, “print_stats”: null, “heater_bed”: null, “extruder”: null}, “response_template”: {“method”: “process_status_update”}}}’
Received 102237.320664: b’{“id”: 140732862899664, “method”: “info”, “params”: {}}’
Received 102237.322940: b’{“id”: 140732862886864, “method”: “objects/list”, “params”: {}}’
Received 102237.383022: b’{“id”: 140732890101584, “method”: “info”, “params”: {}}’
Received 102237.391737: b’{“id”: 140732890814352, “method”: “objects/list”, “params”: {}}’
Received 102237.501662: b’{“id”: 140733194494672, “method”: “objects/subscribe”, “params”: {“objects”: {“webhooks”: null, “print_stats”: null, “heater_bed”: null, “extruder”: null}, “response_template”: {“method”: “process_status_update”}}}’
Received 102237.752461: b’{“id”: 140733194494480, “method”: “objects/subscribe”, “params”: {“objects”: {“gcode”: null, “webhooks”: null, “configfile”: null, “mcu”: null, “gcode_move”: null, “print_stats”: null, “virtual_sdcard”: null, “display_status”: null, “pause_resume”: null, “gcode_macro CANCEL_PRINT”: null, “gcode_macro M0”: null, “heaters”: null, “heater_bed”: null, “fan”: null, “bed_screws”: null, “stepper_enable”: null, “motion_report”: null, “query_endstops”: null, “idle_timeout”: null, “system_stats”: null, “manual_probe”: null, “toolhead”: null, “extruder”: null}, “response_template”: {“method”: “process_status_update”}}}’
Received 102238.004429: b’{“id”: 140732890600464, “method”: “objects/subscribe”, “params”: {“objects”: {“gcode”: null, “webhooks”: null, “configfile”: null, “mcu”: null, “gcode_move”: null, “print_stats”: null, “virtual_sdcard”: null, “display_status”: null, “pause_resume”: null, “gcode_macro CANCEL_PRINT”: null, “gcode_macro M0”: null, “heaters”: null, “heater_bed”: null, “fan”: null, “bed_screws”: null, “stepper_enable”: null, “motion_report”: null, “query_endstops”: null, “idle_timeout”: null, “system_stats”: null, “manual_probe”: null, “toolhead”: null, “extruder”: null}, “response_template”: {“method”: “process_status_update”}}}’
Received 102238.061851: b’{“id”: 140732890092816, “method”: “gcode/help”, “params”: {}}’
Received 102238.409187: b’{“id”: 140732890809680, “method”: “gcode/help”, “params”: {}}’
gcode state: absolute_coord=True absolute_extrude=True base_position=[0.0, 0.0, 0.0, 0.0] last_position=[0.0, 0.0, 0.0, 0.0] homing_position=[0.0, 0.0, 0.0, 0.0] speed_factor=0.016666666666666666 extrude_factor=1.0 speed=25.0
Reactor garbage collection: (102377.610343552, 0.0, 0.0)

Please upload the entire log file.

2 Likes

Agree to @theophile .

The way you did, spaces and special characters are lost and the data is not usable.

klippy (2).log (207.2 KB)

Sorry, here is the full log. I just tried a pid calibrate again.

It looks like there is something wrong with your heater, to make sure I’m not reading this wrong…

Is it taking like a minute or so for your hot end to reach 215 degrees?

If so, what is your hot end and heater type? That’s absurdly slow.

This is a stock ender 5 with creality 4.2.2 board and stock hotend.
That is what I initially thought as well and it may still be the case but when I run marling it seems to work just fine. I can complete a pid tune at 230 deg C. So that made me think is some wierd setting or software glitch with this board and Klipper. This board has the GD chip in it as well.
I guess worst case I’ll but a SKR mini e3

So wait, Let’s go in order.

Which of these order of events is correct?

A.) You were on Marlin, switched to Klipper, Now it doesn’t work.

B.) You were on Marlin, switched to Klipper, it didn’t work, switched back to Marlin and it worked again