Klipper Disconnects Randomly

Basic Information:

Printer Model: Artillery Genius Pro
MCU / Printerboard: Artillery Ruby 1.2
Host / SBC: I dont know what this is…
klippy.log (140.0 KB)

I have a Mac Mini 2007 with upgrades CPU and RAM. I can only install MX Linux AHS, and cannot do much work on it. I decided to plug it to my Artillery Genius Pro and use it for my 3D printing works. I used KIAUH to install Klipper, MoonRaker and Mainsail. Then, I did the necessary setup on the config files. However, Klipper randomly gives error mentioning that Moonracker and Klipper are disconnected.
In the log file, I see the following.

mcu ‘mcu’: Starting serial connect
mcu ‘mcu’: Unable to open serial port: [Errno 2] could not open port /dev/serial/by-path/pci-0000:00:1d.0-usb-0:1:1.0: [Errno 2] No such file or directory: ‘/dev/serial/by-path/pci-0000:00:1d.0-usb-0:1:1.0’
webhooks client 124310830158864: New connection
webhooks client 124310830158864: Client info {‘program’: ‘Moonraker’, ‘version’: ‘v0.8.0-354-gba94285’}
mcu ‘mcu’: Unable to open serial port: [Errno 5] could not open port /dev/serial/by-path/pci-0000:00:1d.0-usb-0:1:1.0: [Errno 5] Input/output error: ‘/dev/serial/by-path/pci-0000:00:1d.0-usb-0:1:1.0’

I could not find something to fix this issue but after some (maybe 10-30) restarts, the connection between Moonraker and Klipper seems to be established, and it starts working fine untill an unknown time.

I have tested this with another PC which has Linux Mint XFCE, and received the same error. I have attached my Klipper.log, I hope it will be helpful. This situation became very frustrating, I am having only 1 of my 3 prints complete. Your help in this direction is highly appreciated.

Best regards.
bkarpuz

This is going to sound cliche, but have you tried another USB cable? That error usually means it’s having trouble physically connecting.

Flaky connections are a common effect with marginally functional cables.

I have tried 3 different USB cables. I have even tried the shortest cable (using for Arduino) to prevent energy loss but the same situation happens.

Wait, Is it randomly disconnecting or is it ever actually connecting? Your log doesn’t show it ever connecting.

I got the log file right after the connection failed. As I said, after several firmware restarts and PC reboots, the connection is established.

I have tried another cable, and you know what? It did work. I cannot believe this. @TheFuzzyGiggler Thank you, you made me suspicious about this as I was so sure that the problem was something else…

Now, I have a 3 meters UGreen USB A to USB B cable, and I am having a very good connection.

2 Likes