Moonraker not connected to klipper

Basic Information:

Printer Model: Ender 3 V2
MCU / Printerboard:4.2.7

klippy (1).log (152.7 KB)


I have currently installed mainsailos via raspberry pi imager. Running that on a pi 4b. Get the error that moonraker is not connected to klipper and to check klippy_uds_address.

I’ve tried everything i can to figure out what is wrong. Nothing has worked.

I have reinstalled mainsailos multiple times and even tried it on a pi 3 but still can’t get past this error

Your error message is:

mcu 'rpi': Unable to open port: [Errno 2] No such file or directory: '/tmp/klipper_host_mcu'

Your setting in printer.cfg

[mcu rpi]
serial = /tmp/klipper_host_mcu

According to the startup arguments, this should be /home/pi/printer_data/comms/klippy.serial

Thank you. In printer.cfg I can’t see a section [mcu rpi] there is only [mcu]

According to the log you provided, it is there.

This is the printer.cfg file that i can see and can’t see that section

printer.cfg (9.8 KB)

from line 312

Good luck, hcet14

Thank you. Found it. I looked multiple time

Added the line to [mcu rpi] and it hasn’t made any difference

klippy.log (566.7 KB)

new klippy.log after adding that line

Have you done the things mentioned here?

As far as you need them…

Why don’t you start over by answering my stupid questions :wink:

What do you want to do?
Please describe your HW setup.

Just running Klipper on your Ender?

Do you have an ADXL345 hooked up?

Moonraker is connected see line 15508.

webhooks client 1965300248: Client info {'program': 'Moonraker', 'version': 'v0.8.0-41-g348b7f5'}

Do you really need the RPi as a secondary MCU?

At the moment I have a ender 3 v2 with 4.2.7 board, sprite pro extruder, cr touch. No adxl345

That now has klipper firmware on it.

Rpi is attached to ender via usb. Rpi has mainsailos installed. I connect to the rpi via ssh and the ip address on my Windows tablet.

As indicated by @EddyMI3D, follow the instructions in the link he provided. The error messages in your log are not related to Moonraker.

Understood. One question, your cr touch is connected to your 4.2.7 board?

If yes, you don’t need the RPi as a secondary MCU.

My advise would be, start over. Follow the excellent Klipper documentation. Don’t copy stuff from somewhere in the www (particularly macros). If your Ender is pretty original (not regarding the extender), start with klipper/config/printer-creality-ender3-v2-2020.cfg at master · Klipper3d/klipper · GitHub. Just use stuff you understand. Do you know GitHub - th33xitus/kiauh: Klipper Installation And Update Helper? Have a look here About the Knowledge Base category / Table of Contents. If you have problems come back here and use the “search” button first. Almost everything was asked before :wink: I guess you come from Marlin, if yes you have to read a lot. If you don’t find the answer, ask here. People here are friendly and helpful.

Followed the instructions in the link and still the same

Please provide a new log.

I don’t have a spare laptop to put linux on so that is why i have the rpi running klipper.

klippy (2).log (143.9 KB)

Does it work with

[mcu host]
serial: /tmp/klipper_host_mcu

instead of

[mcu rpi]
serial: /home/pi/printer_data/comms/klippy.serial


1 Like

Follow @EddyMI3D advice and in addition it looks like the “host mcu” process is not correctly started.

  1. Make sure to have followed the above link to the letter. In doubt, repeat it. Especially important

    cd ~/klipper/
    sudo cp ./scripts/klipper-mcu.service /etc/systemd/system/
    sudo systemctl enable klipper-mcu.service
  2. Issue the commands (or reboot)

    • sudo service klipper-mcu restart
    • sudo service klipper restart
  3. Show the output of ls -al /home/pi/printer_data/comms/klippy.serial