Moonraker can't connect to Klipper!

Basic Information:

Printer Model: Ender 3 V2
MCU / Printerboard: 4.2.7

Describe your issue:

Everything was working fine and today I get this error. Moonraker can’t connect to Klipper!

Please check if the Klipper service is running and klippy_uds_address is correctly configured in the moonraker.conf.

Is the Klipper service running? Is the klippy_uds_address correctly configured in the moonraker.conf?

Everything seem to be fine. I ended up reinstalling klipper and moonraker. That took care of the issue. Still trying to figure out why it would happen in the first place. Im using a pc with linux mint. I tried tl rjn the commands to make sure klipper was tunning and kept getting errors

There’s a good chance those errors were telling you what the problem was.

I’m having this same issue. Besides, reinstalling klipper and moonraker, what else did you have to do? For example, did you have to edit specific files, create specific files, etc.?

As soon as I reinstalled it it worked fortunately I didn’t have to do anything else

1 Like

I got it working somehow. I followed this gentleman’s guide because that is the touchscreen I would include with the system. After installing MainsailOS 64bit on the MicroSD, and doing the first boot, I then SSH’d into the RPi, installed KIAUH following Th33xitus’ instructions, and installed KlipperScreen (I know that isn’t relevant for this issue in this thread.) I then uploaded the needed printer.cfg file for my printer via SFTP. Then, I went to the mailsail.local page and updated everything installed via the Update Manager. Did a hard reboot. Then went to the Klipper Installation Instructions and followed the commands for “Building and flashing the micro-controller” so that I would be able to connect to the printer itself, via SSH. It wasn’t working for a bit, keep restarting and restarting firmware, etc. So I ran a shutdown command via SSH on the RPi, and let it turn off completely. Removed the power supply connected to the RPi, then reconnected and turned it back on, and everything is connected and working now.

Good times for a week of frustration :joy:

Hi! - I just ran into this issue at home. I am using an OrangePi 5 for my homelab to run mainsail in. In my case, the error code pointed to check my moonraker.config section under:

klippy_uds_address: /home/pi/printer_data/comms/klippy.sock

Because this is an OrangePi, by default my user was orangepi and not pi. All I had to do was fix this in the kluppu_uds_address path :

klippy_uds_address: /home/orangepi/printer_data/comms/klippy.sock

I also doubled check that the service was running with systemctl status klipper.service

Hope this helps!