Klipper fails to home after print

After printing the hot end sits on the top of the printed part due to a failure to home. I would say 95% of this happens. Every so often it will home correctly.

If I run G28 X by hand from the terminal it works every time, even after it fails. I have also tried G28 X0 with the same results. I have also confirmed that the end gcode is actually at the end of my sliced file and it is.

Here is my end gcode from SuperSlicer

M104 S0 ; turn off temperature
G28 X  ; home X axis
M84     ; disable motors

Here is the log file. It happened on the last print of the log.
klippy.zip (593.2 KB)

If you need any more information or logs please let me know and I will be happy to get that for you.

Hello @hcker2000 !

You may insert a M400 after the G28 command:

I would use G1 X0 instead of G28 X

  1. The printer is already homed
  2. It’s a bit faster

I use G28 only at the start of a print

Ok let me try and add the M400 and see if that resolves the issue

Are the M112 commands in your log intentional?

1 Like

The ones before the last print are me putting them in via terminal