Klipper hangs on Starting heater checks for extruder

Basic Information:

Printer Model: Ender 3 V2 and Ender 2 Pro
MCU / Printerboard: BTT SKR Mini E3 V3

Fill out above information and in all cases attach your klippy.log file. Pasting your printer.cfg is not needed

Describe your issue:

Today I decided to switch from Raspberry PIs to a NUC similar machine so I can run both my printers from the same device. The install and everything works great with kiauh, but I cannot get a proper connection to the printers. Klipper just hangs at Starting heater checks for extruder.

On the Raspberry PIs I was running OctoPi, on the new machine I am running Ubuntu Server 22.04. Here is a neofetch output about the hardware:

OS: Ubuntu 22.04.1 LTS x86_64 
Host: GB-BACE-3000-SBE 1.x 
Kernel: 5.15.0-53-generic 
Uptime: 23 mins 
Packages: 806 (dpkg), 4 (snap) 
Shell: bash 5.1.16 
Terminal: /dev/pts/0 
CPU: Intel Celeron N3000 (2) @ 2.080GHz 
GPU: Intel Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx 
Memory: 706MiB / 7798MiB 

The printers are connected using Amazon Basics USB cables. The PC only has USB 3.0 ports, but I doubt that that causes the issues.

Can someone point me in the right direction? Nothing google spit out worked. ModemManager is uninstalled and brltty is not installed either.

Edit: After trying with Ubuntu 18.04.6 LTS I get the same result.

Edit 2: I tried Raspberry PI OS Bullseye a few minutes ago and got the same issue. And with x86_64 Debian Bullseye I have the same issue, too.

ender-3-v2.log (5.6 KB)

Hello @DerKnerd !

[heater_fan controller_fan]
pin = PB15
heater = heater_bed
heater_temp = 45.0

This is meant to be used for the heat break fan to prevent heat creep in the hotend.
heater = heater_bed makes no sense here. You should use heater = extruder

Hey @EddyMI3D,

sadly that didn’t fix the issue.

Does it just hang or is there a message?

The klippy.log just ends with:

Starting heater checks for heater_bed
Starting heater checks for extruder

but with no runtime info or error messages.

It just hangs at that point until I restart klipper. After the restart it hangs at that point too. I just tested it with OctoPi and have the same issue. Is there maybe a bug in the newest firmware?

Nevermind, I am stupid. It all works fine and I can connect to the printer via UDS.

1 Like