Klipper is dirty

Basic Information:

Printer Model: tronxy x5sa
MCU / Printerboard:manta m8p
klippy (9).log (689.4 KB)

some how my klipper v0.11.0-200>v0.11.0-205 is “dirty” i have never opend the klipper file. when I try a hard recovery I get.

08:52:32 Application klipper: Attempting Repo Recovery…
08:52:32 Git Repo klipper: Starting Clone Recovery…
08:52:32 Cloning into ‘/home/biqu/.klipper_repo_backup’…
08:57:13 fatal: unable to access ‘GitHub - Klipper3d/klipper: Klipper is a 3d-printer firmware’: gnutls_handshake() failed: The TLS connection was non-properly terminated.
08:57:13 Git Repo klipper: Git Clone Failed
08:57:13 Error Recovering klipper
08:57:13 Git Clone Error


Can you open your config files? If so, than just copy them somewhere, along with a list of all your setting changes and reflash klipper. That’s what I did once and it worked.

Hope this helps!

How do you reflash klipper? Ware is that totorial?


Well, there is a pretty long process, it involves reflashing your btt cb1. Ed’s 3d tech on yt has a series of really good tutorials on there. check them out, that’s how I flashed my board. I would only do this if you found out no other way to recover klipper. If you do end up reflashing, then again, make sure you copy all your config files over to another spot where you can then copy them back later.

Hope this helps!

Just to be on the same page: “Reflashing” usually refers to burn the firmware to a Klipper hardware again, i.e. make menuconfig followed by make flash ...

It is very unlikely that the error can be solved this way.

Klipper “dirty” means that the Klipper files in /home/biqu/klipper/ do no longer match to the pristine main line on GitHub - Klipper3d/klipper: Klipper is a 3d-printer firmware. This “corruption” could have happened intentionally or unintentionally.

Ther error gnutls_handshake() failed: The TLS connection was non-properly terminated. is an error from the underlying git system that is used to manage the files in /home/biqu/klipper/ and points rather to an error on Linux level regarding certificates and encryptions.

You could try following approach from the shell

sudo service klipper stop
cd ~
rm -rf ~/klipper
git clone https://github.com/Klipper3d/klipper 
sudo service klipper start

If this does not work I recommend to prepare a new SD card with a new Linux and redo the installation from there. Unlikely you will get it fixed without Linux admin knowledge.