Klipper screen not starting

Hi,

I have klipper installed but have been unable to get klipper screen to work. I have tried doing it by installing fluiddpi and following the instructions to install klipper screen. I have also tried doing it by installing raspberry pi os lite and using kiauh. Both ways klipper screen does start and I just get the console on the screen attached to the raspberry pi.

I have followed the troubleshooting guide and here are the results in a google doc. Klipper screen - Google Docs

Not sure what to try next? If I were to just connect a keyboard to the raspberry pi is there a way to manually start klipper screen just to see if it works?

Apr 06 01:40:43 raspberrypi xinit[2326]: Fatal server error:
Apr 06 01:40:43 raspberrypi xinit[2326]: (EE) xf86OpenConsole: Cannot open virtual console 2 (Permission denied)

This looks like xorg (the graphics system) cannot start because of permission problems.
I’m not sure though why, could be many things. One thing to check would be if you can start xorg manually with that user.

Another thing could be that there is something wrong with your xorg installation in general (missing packages for example) as you mention Raspberry Pi OS Lite (which doesn’t contain xorg by default if I’m not mistaken). You could try using the full Raspberry Pi OS with graphical system already included.

When you say installing fluiddpi, did you mean the fluiddpi image? That should work just fine, at least it did for me as everything is nicely pre-configured, I just selected it in kiauh and it worked without issue.

Thanks for the reply.

Yes for the first try I used the fluiddpi image. FluiddPI - Fluidd

I have tried again using the graphical raspberry pi image as suggested on another forum and I got the same result.

If you use the fluiddpi image, it should work pretty easily.

Download and write fluiddpi image to a sdcard.
login via ssh as user “pi”, then:

git clone https://github.com/th33xitus/kiauh.git
cd kiauh
chmod +x kiauh.sh scripts/*
./kiauh.sh

Inside the kiauh menue choose install Klipperscreen, wait some time, Klipperscreen will pop up and run. Atleast it did for me on a Pi4 about 2-3 weeks ago.

Nice of this guy that was asking for help to not even bother to respond to that helpful reply 27 days ago.
Might have been helpful if he reported back on this.
But nothing.
They just drop off like that after engaging asking for and engaging help.

I am having the same or similar problem.
I have Klipper running just fine but cannot get KilpperScreen to startup.
There is no log file created in /tmp.
And was never an Xorg log created at all until I once manually tried “startx”.
I do not get any additional logging (xorg or klipperscreen in /tmp from just rebooting.
In fact I don’t get any log from klipperscreen at all.
No klipper screen nor xorg log entries after a reboot.
indicating to me xorg / klipperscreen are not even trying to start.
If I try startx as pi or as root The screen goes black and then I see
“pi@fluidpi~#”
text in the upper left corner of the screen and I have the “X” mouse pointer center screen
and if I have mouse plugged in I can move it.

I’m not familiar with the software.
And I am still setting things up on the bench.
The MCU is not entirely setup yet,
I am lacking one thermal sensor and get the expected:
“MCU ‘mcu’ shutdown: ADC out of range
This generally occurs when a heater temperature exceeds
its configured min_temp or max_temp.
Once the underlying issue is corrected, use the
“FIRMWARE_RESTART” command to reset the firmware, reload the
config, and restart the host software.
Printer is shutdown” message.

But I can see the live view of the one working thermal sensor I have plugged in.

Again not very familiar with the software-
I realize it’s possible that since the “Printer is shutdown” or not fully operational yet that it’s possible
that KilpperScreen is not even being started because of this. But have not idea if that is true or not.
Or a reason for klipperscreen not to even start yet.
But I’m guessing not.

I tried the instructions above… “git clone GitHub - th33xitus/kiauh: Klipper Installation And Update Helper

But it is requiring a username and password.
It is not anonymous or open access.
I signed up here just to post this reply and question.

I also ran into this brick wall on my first install of KlipperScreen.

In my case, I installed the FluiddKlipper/Moonraker package, then tried to install KlipperScreen.

All I could get was a console on the rPi screen. Following the Troubleshooting instructions failed at the “change frame buffer” step, because the 99-…cfg file was named 99-…~ instead, and I could not rename it.

One of my problems may have been that Klipper was banging its head against an error in my printer.cfg file, where the kind soul who prepared it for me had left in that file a copy of the header for the CONFIG_SAVE entries section.

It seems to me like Klipper may not parse all configuration files correctly if any configuration files contain syntax errors. In the middle of an installation, either Klipper is unable to report such problems, or the reports get lost in the screed of other messages scrolling by on the screen.

I started all over, installed the MainsailOS package, and used KIUAH to handle all of the installations and updates.
It took quite a while to run through all of the updates, but the result was a fully functional system, including KlipperScreen.

I am only 3 days into this install, and I am hopelessly “at sea” if I “goof-up” anything on my pi, but so far I am operating ok with both KlipperScreen and Mainsail controlling the one CR6-SE printer.