Locking IP address on CB1 /Manta 8P

I resurected my Mendel90 using a BTT Manta 8P with CB1 and have suceeded in getting it all working. My home network is stable using an eero 6 hub. All other devices on my network connect and will retain the same IP address as before. The CB1 -[wireless] and Manta 8P -[wired] will connect to different addresses without rhyme or reason. Is there a setting I can make specifying what address to use ?

So this is an issue with the Frontend (Mainsail, Fluidd or KlipperScreen) ?

To my understanding it would be Mainsail, the web based interface I use to control the printer. Maybe it is an underlying Linux configuration setting but I am wondering how I might get the IP address to stay the same everytime I power up.

1 Like

This is purely a Linux issue. Google how to set a static IP on Debian from the command line.

1 Like

easiest way to do it is assign a static IP to your printer in the router using the MAC address.

Thank you all for your help. Everything stable now

1 Like