Manta M8P+CB1+U2C+EBB36

Basic Information:

Printer Model: Zero G Mercury
MCU / Printerboard: Manta M8P V1

Fill out above information and in all cases attach your klippy.log file. Pasting your printer.cfg is not needed
When pasting code or config snippets use the code tags </> in the menu above

Describe your issue:

hey everyone i am getting my new electronics setup with the above. i have already setup klipper and mainsail on the Manta M8P and already tested things work before trying to setup can. i believe i have a v1 manta board. i am following this guide (Klipper CAN bus guide for Bigtreetech U2C and EBB boards - YouTube) with this referene(KlipperMisc/BigTreeTech-U2C at master · meteyou/KlipperMisc · GitHub) (KlipperMisc/BigTreeTech-EBB36-v1.1 at master · meteyou/KlipperMisc · GitHub). but when i come to flash the EBB 36 with klipper i can an error with this command (python3 ~/CanBoot/scripts/ -i can0 -q).

The solution is in your screenshot. Run

pip3 install pyserial

you are correct, for that error yes. i was able to fix this. i am stuck further along in the documenation. that is a photo from earlier in my disagnoses. and yes i was stupid for using that image as well as missing that error initially.

this is the step i am stuck on.

here is the error i get when i look for can0.

some other checks i have done per others recommendations.



What is the content of /etc/network/interfaces?


at the moment this

this was tried as well.

I’m not sure I understand what you’re doing. You appear to have flashed Canboot for a USB interface which is why you needed pyserial. Now you’re trying to flash the board on the CAN interface. You can’t mix and match this way. If you want to use the board over CAN, then you need to choose CAN as the interface for both Canboot and Klipper.

originally following the metoyou guide i did flash canboot onto the U2C. at this point i have replashed the U2C with candlelight fw for the big tree tech u2c and have the boot loader installed on the ebb 36. if i follow the teachin tech guide to T i still get an error. i can post later what i get.

i have reflashed the U2C with candle light fw and still get this error message. no canboot used at all

All I can say is I’m using CB1 boards on Manta M4Ps on two different printers. One is using a UCCB with candlelight, and the other has a CANable clone from MKS with candlelight. Both work great with my toolhead boards. You do not appear to have a working can0 interface, so you need to look at the U2C and figure out if it’s a firmware or hardware issue.

going to get a replace U2C and see if thats the issue.

I would verify you flashed the correct candlelight firmware on the U2C first. I believe they make different versions of it with different MCUs.

btt u2c stm32g0 chip

i have tried this version

and this version

niether reference the chip i have.

btt manual for U2C shows this fork but i get a fatal error when i try to use this repository.

The G0 repository is the correct one. I’ve seen others post that they got the board working with that firmware. You should contact BTT support if you can’t get it to build.

so when i run these commands i should use the second link in the above image?