Mcu shutdown: Timer too close

Basic Information:

Printer Model: Own constrction simular to Rat Rig V-Core 3
MCU / Printerboard: Btt Octopus v1.1
klippy 2.log (1.2 MB)

Describe your issue:

Hey guys,

every time i‘m try to home my y-axis my printer runs in the „ ‘mcu’ shutdown: Timer too close“ Error.
I tried serval hours to find the issue, but my programming skills are too poor to solve this problem or basicly read/ understand the log file.
Can you please help me to find the reason/ solution for the issue and bring the printer alive for the first time.

Hello @jermaine !

You may have a look in this:

Hey @EddyMI3D , I read serval posts about this error.
I tried all solutions but nothing helped.

Best regards

Could you describe your host system you’re using including the operating system and what’s running on it (all the applications)?

1 Like

I’m running a RPI4 8GB with and OctopusV1.1 board.
Before i tried the RPI 4 i used a RPI3b with the same error.
The raspberry runs klipper with the newest updates etc…
I installed only Klipper on The RPI nothing else.
Stepper drivers are TMC2209.
What do you mean with application ?

Best regardes

I’m wondering about anything else running on the rPi - any webcams or any other devices?

Hey, there is no webcam or such things running.
The printer is in a prototype state where it only can print.
If it finally runs (to minimize error origins) I add things like a webcam.

Starting from line 12 in your klippy.log:

Unable to open config file /home/pi/printer_data/config/printer.cfg
Traceback (most recent call last):
File “/home/pi/klipper/klippy/”, line 158, in _read_config_file
f = open(filename, ‘r’)
FileNotFoundError: [Errno 2] No such file or directory: ‘/home/pi/printer_data/config/printer.cfg’
Config error

Where is your printer.cfg located on your RPi? I would not expect such an error.

Good luck, hcet14

hey @hcet14,
thx for your replay.
I search for the config-file. It’s located in /home/pi/printer_data/config/*.
I don’t know the reason for this error but for me it seems the path is correct.