Random - "Lost communication with MCU 'mcu'"

Basic Information:

Printer Model: X5SA Pro
MCU / Printerboard: XCY-V6-191017
klippy.zip (1.0 MB)

my printer was running reliably till I ran input shaper on it, now I randomly get the “Lost communication with MCU ‘mcu’” error.

I getting better results with the input shaper, except for this… but I’m not sure how to disable it to see if that’s the problem.

I thought maybe my raspberry pi might be getting too hot, so I put a fan on that.
I’ve tried printing the same thing 3 times, and it disconnected at different times. thought maybe I was printing too fast, so I slowed it down and I’m still having the same issue.

Any ideas would be great.

(I had to zip the klippy log because it was too big)

Thank you.

In your logs I did see 3 times that you did experienced communication issue.
First and Last instances of error look the same way - your system periodically have issues and klipper trying to recover by retransmitting data, at some particular moment data just not going and you are getting timeout.
When your system experience those issues system load can be at 1.25 or at 0.4 load - usually this means that load on your system don’t have impact on this, also I didn’t see issues with available memory.

Second instance was completely different, no retransmits, everything was fine, then in one moment serial device just reply with “EOF” message - usually this means OS did close that device (unplug it)

Most of the times this kind of issues indicate that you have faulty connection between klipper and MCU, it can be USB cable (some wire is broken) or Connector Ports don’t have reliable connection with the cable. Sometime it can be faulty USB controller.

Thank you for your diagnosis. I tried moving the cable to a different USB port on the pi last night, same result, then before bed, I moved it to the powered USB hub I have my cameras on, and it actually finished the print (I was kind of surprised that it worked)

Could it be a power issue?

You can monitor the state of retransmission in klippy log file, almost each second klippy is adding a line with “Stats”, retransmit_bytes - indicating how much byte did we lose during retransmission, when it’s increasing - this means issues, more often it happening the closer is some fault :slight_smile:

Thank you for the information. I was going to ask how you could tell what was causing the problem.

BTW, ever since having the mcu on the powered hub, its been printing reliably.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.