Several errors causing Lost communication with MCU 'mcu'

Basic Information:

Printer Model: Custom
MCU / Printerboard: SKR 2.0 rev B

Fill out above information and in all cases attach your klippy.log file. Pasting your printer.cfg is not needed
Be sure to check our Knowledge Base and in particular this and this post

Describe your issue:


my prints keep failing no matter what I try. Its mainly an issue with larger prints then with smaller ones. Its never failing at the exact same position but same layer I think. Can vary though. I looked into the klippy log and I see serveral errors like GSTAT TMC error for all tmc drivers and OSError: [Errno 11] Resource temporarily unavailable…
What I tried so far is lowering the current of the drivers, active cooling them, exchanging the steppers and cables, testing the connections, exchanging the usb cable and reflashing the board.
Last klippy.log is attached.

Nothing has worked so far and I am getting frustrated. I appreciate any help and tips.

Best regards Vincent
klippy(13).log (1.2 MB)

Your bandwidth is quite high Advanced Trouble-Shooting / Graphing Klipper.

More than half of your klippy.log is filled with: Unknown command:“M205”
Maybe Crealty Ender 3 unknow command M205 over and over and over · Issue #610 · Klipper3d/klipper · GitHub?

Good luck, hcet14

Thanks for the replies!
I created a makro to filter out the unknown command. As far as I know m205 is created by cura and is ignored by klipper in general. Without the unknown command showing up my print failed again. I did a fresh installation of the raspberry pi and reflashed the board as well. Bandwidth is still high. Might be due to my high pulses per rotation setting of 40000p/rotation?!

I tested all my connections and the power supply. There is nothing wrong with it. The ps has 500watts and is only supplying the extruder, hotend, bed and z motors. It should have plenty of reserves. The usb cable is a quality cable and is not crossing any other cables. Its completely seperate.
I added another klippy log.
OSError: [Errno 11] Resource temporarily unavailable is appearing several times at the end.
I am printing a case which is relatively homogeneous. I dont understand why it is failing out of the blue.

Yes, I agree.

Line 1360-1364 in your klippy.log reports:
Write g-code response
Traceback (most recent call last):
File “/home/pi/klipper/klippy/”, line 446, in _respond_raw
os.write(self.fd, (msg+“\n”).encode())
OSError: [Errno 11] Resource temporarily unavailable

I guess your slicer produced some g-code, which “” doesn’t like. The last post Reddit - Dive into anything from Ornery_Watercress_43 is suggesting to use a different slicer. I would give it a try.

Good luck, hcet14