Unable to get Katapult UUI

Basic Information:

Printer Model: Voron 2.4
MCU / Printerboard: octopus
Host / SBC: BTTPI SB2209 with U2C
klippy.log Not applicable

Describe your issue:

…“Detected UUID: 41b40a950e8a, Application: Klipper this should be Application: Katapult”
Have deleted Klipper and Katapult but keep getting the same result. I have changed the BTT canbus 2209 Thought I might have damaged the old one. Looked up the trouble shooting which indicates starting the machine again and rebooting which I have done also many times.
I have followed Esoterical very clear instructions for toolhead flashing each time but have the same results
When I download Katapult it says successful download.
Is there any way I can view the serial numbers in mainsail thought I had seen that you could somewhere in all the reading I have done
Any help would be much appreciated as I am sure I have missed something simple


Screenshot config 10 June 2024

Just to be sure:
What firmware is on your U2C? If 41b40a950e8a allways reports Application: Klipper this sounds like it is your U2C.
When flashing katapult over USB have just this one device connected to the pi while flashing.

Sidenote: What octopus version do you have? Octopus is also usable as a usb-can bridge.

Thank you but I tried again with only one item attached still the same result. I do have an octopus 1.1 but all the things I read advised that the U2c is maybe the best way to go.
Think I will have one more go right back to the main board again and see what happens.
Any more advice gratefully received.

You have a BTT Pi - do you have the U2C module for it or the normal U2C V2?

There are two mcu version of the octopus v1.1 - F407 and F446 - which one do you have?

Hi thanks for helping I have the 446 version

That answers half of my questions. What about my first one?

Sorry I missed the first one I have a BTT U2C v2.1

How have you wired the BTT U2C?

I don’t know how long you’ve been here, but over the past few weeks, there have been some lively discussions regarding the BTT U2C.

Thanks I must have missed those will look back I take that they are under U2C

I have wired it as per picture

So, on the left end it’s the USB C connector, in the middle facing downward it’s a Microfit connector passing power and the two CAN signals and on the right is the power. Correct?

Now, using a DMM, check the continuity of the wires and make sure power is getting to your toolhead board.

Thanks for your help will try tomorrow

All checked out shows flashing red light on toolhead showing that it is in katapult mode but still comes back biqu@TimVoron:~$ python3 ~/katapult/scripts/flashtool.py -i can0 -q
Resetting all bootloader node IDs…
Checking for Katapult nodes…
Detected UUID: 41b40a950e8a, Application: Klipper
Query Complete
Not Katapult application
I have followed Esoterical and started again 4 times now still the same result

Sorry, what is the toolhead controller that you’re using? I don’t seem to be able to find it in this thread.

Along with that, what are the “Esoterical” instructions that you’re going through?

BTTPI SB2209 with U2C with BTT EBB sb 2209 can v1.0
Toolhead Flashing | Esoterical’s CANBus Guide

Sorry for taking so long to get back to you.

Now, for your BTT EBB SB2209, how did you configure your make?

From your original post, it looks like you followed the “Esoterical” example which you’ve posted as:

Screenshot config 10 June 2024

BUT you aren’t working with a toolhead controller with a STM32G0B1 MCU, you’re working with the RP2040 which should have the make menuconfig of:

as detailed in the BTT EBB SB2209 Build Guide which you can find here:

Can you confirm the make menuconfig you used?

The Esoterical instructions are all right, but BTT did a good job on their instructions (they start at page 25 of the Build Guide) - could I suggest that you follow them and let us know how you make out?