ADXL345 inputshaper not working

Basic Information:

Printer Model: Sapphire Pro
MCU / Printerboard: Raspberry Pi 4B, stock Sapphire Pro Mainboard

Describe your issue:

Hello :slight_smile:
I am really getting desperate with the setup of inputshaper.
I tried to set it up last week without any luck. Did I miss anything? Thank you for your help!

Hardware: Raspberry Pi 4B with klipperscreen, ADXL345, Sapphire Pro with 2 month old klipper install,

As soon as I add the code from the manual klipper does not start anymore.

Error in the dashboard:

MCU 'rpi' error during config: Unable to open spi device 
Once the underlying issue is corrected, use the 
"FIRMWARE_RESTART" command to reset the firmware, reload the 
config, and restart the host software. 
Error configuring printer

What did I do:
I followed the video from Nero 3D
Guide from klipper Measuring_Resonances + RPi_microcontroller

My ADXL345 looks like the picture on the right and connected it like that, I swapped 100cm cables with 20cm jumper cables as a test.
SPI is active.
systemctl status klipper-mcu is active.
Folder exists lrwxrwxrwx 1 root root 10 Sep 17 12:13 klipper_host_mcu -> /dev/pts/0
Second ADXL345 sensor tested without luck.

I tried pretty much everything I could find. SD card backed up and copied to new SD card and tested other Pi 4B.

Some thougts:
Could klipper screen/drivers cause problems for the GPIO Pins and adxl345?
Is there a problem with my printer.cfg?
Is klipper damaged? I did not install much. Only klipperscreen with driver, obico and mobileraker.
klippy.log (1.7 MB)


grep spi /boot/config.txt


ls /dev/spi*

Copy and paste output here

1 Like

Thank you :slight_smile:

pi@klipper:~ $ grep spi /boot/config.txt

pi@klipper:~ $ ls /dev/spi*
ls: cannot access ‘/dev/spi*’: No such file or directory

Try adding
to the /boot/config.txt file, then reboot

1 Like

Thank you, now I am a step further :slight_smile:
Had to uncommentdtoverlay=mhs395:rotate=90
I dont know from what that exactly is. Maybe Screen?

With dtoverlay=spi0-cs it now starts and works after 2 reboots. I dont know why I needed 2 but after the first I did not get any values of the sensor.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.