Blank Screen "sometimes"

  • Printer Model: LDO Trident 300mm
  • MCU / Printerboard: Octopus v1.1

I have been using this 7" HDMI display, everything works fine, plug and play.

It worked fine during Debian installation too. I am running a thin client Linux/Kiauh

When I first installed KlipperScreen, it would not work until I ran these:

So far so good but from time to time tho, it just stops working with a blank screen, restarting the service doesn’t do anything.

The logs shows no error other than [] - 404 Client Error>>Not Found for url>>

  1. systemctl status KlipperScreen shows no error
  2. journalctl -xe -u KlipperScreen shows no error
  3. tail -f printer_data/logs/KlipperScreen.log shows no error
  4. tail -1000f /var/log/Xorg.0.log shows no error either

The fix for this is to restart the the thin client which is wild

Just wondering if anybody has crossed this problem before coz it is driving me nuts atm.

Thank you for any help.

Maybe a hardware issue with display’s PSU, the display itself or the HDMI driver (hardware) on the SBC.

Hmm but it worked fine during Debian installation and all, I also used the same HDMI display to setup home assistant on another thin client also connected via HDMI.

It seems to be something related with KlipperScreen causing this problem.

Good guess, did you look in your KlipperScreen.log? Troubleshooting - KlipperScreen

Good luck, hcet14

So, it looks like the power saving is the issue.

The display turns off to save energy but when the print finishes, at some point it cannot come back so the display turns on but with a “blank screen”

I’ll try disabling this power saving stuff.

So using another post where his display was set as 100, I assume my monitor was 0 (zero): xset -display :0 q

Among a few outputs I had this:

Screen Saver:
  prefer blanking:  yes    allow exposures:  yes
  timeout:  0    cycle:  600

So I gave it a shot with xset -display :0 s noblank to disable the screen saver, fair enough: xset -display :0 q

Screen saver is disable.
Will monitor things but this should be it.

Screen Saver:
  prefer blanking:  no    allow exposures:  yes
  timeout:  0    cycle:  600
1 Like

The above indeed solved the problem.

The HDMI display power saving is triggered but it no longer have a blank screen which was causing the problem.

Wake the screen up and everything works as expected.

1 Like