BTT Manta M8P Extruder

Basic Information:

Geeetech A20



Hi all

Phil here, noob with Klipper

i have purchased a BTTManta M8P to replace the failing stock board.

i have had “fun” working out how to install and configure Klipper, and working my way through all the challenges that that threw up.

So far i have the bed and nozzle heaters working, x and y on sensor less homing. Z controlled by a BLTouch.

Z offset configured. everything finally coming together, all bar the extruder!!!

if i run stepper_buzz on x, y and z i get the expected oscillation. absolutely nothing.

for fault finding i swapped the cable for x and the extruder.

re running the stepper_buzz i now have the extruder oscillating but x is stagnant.

stepper driver i hear you say, i then swapped the driver for x and the extruder. extruder, plugged into x oscillates but x, in the extruder port will not.

all i can see left is the config…

i have searched and read every thing i can find regarding the correct pin assignment and it looks like there may be an issue with motor 6,7 and 8 but they all state the same config for motor 5

is there anyone out there that could possibly shed some light as to where to look next be fore i pull my remaining hair out!!!

i have tried on other motor ports but to no avail

thanks in advance


Describe your issue:

klippy (8).log (687.5 KB)

step_pin = !PD3
dir_pin = PD2
enable_pin = PD5
endstop_pin = probe:z_virtual_endstop
microsteps = 16
rotation_distance = 8

Change the enable pin to !PD5.

Hi jakep_82
thanks for that,

have made the change, still no extruder!!??

Please post a new log.

klippy (9).log (1.2 MB)
sending again

@jakep_82 asked you to change this line:

enable_pin = PD5


enable_pin = !PD5

If the extruder does not work, try this:

enable_pin = PD1


enable_pin = !PD1

BTW @jakep_82 : Please use code braces when you post code:

What version is your M8P?
The stepper pins for M6 - M8 are different between the two versions.

Is the cable plugged into the 4th or 5th connection on the Manta board? it has the 3rd and 4th running in parallel.

1 Like

Hi guys
I run 2 z axis motors. 1 to4 look after motion and using 5 for the extruder.

@NAPCAL … my saviour.
Now have extruder in motor8 configured to v1.1.

Still getting driver errors. The 2209 is now in standalone mode I can extrude molten plastic​:+1::grinning::innocent:

The next hurdle is getting my head around macros. Configuration and calibration.

Thanx everyone for the advice


1 Like