Cant see MCU in mainsail, but can find serial

Printer Model: VZbot 330
MCU / Printerboard: BTT Manta m8p and EBB36can
klippy (12).log (604.4 KB)

Having issues with my manta and can setup

so was homing the other day and printer shutdown. tried to reboot and nothing. since then ive not been able to get it to load at all. at the time i was using canbus communication. ive since changed to usb comunication for the can board as i was having some canbus issues before so throught this might be the issue. both boards come up in LSUSB, and i can find both serials, both serials are correct in the printer.cfg

however i get the unable to connect to mcu error, somtimes for the mainboard, somtimes for the can board

ive been at this on and off for a few days now and im pretty lost

ive recompiled and reflashed the firmwares when i switched to usb communication, nothing changed in the printer.cfg before the failure, one miunte it was working then crashed and this

thanks in advance for any advice

So got it working reflashing again, now my temps are all over the place, won’t home, think the boards f***ed

pls double check your thermistor pin in your config and the wire of the thermistor. it looks like a not plugged in thermistor (or wrong port in the config).

I’ve tried different thermistors, changed pins in config, changed the physical port I’ve connected too, they are all bad

I also have no fan control, won’t home

I think something’s gone wrong with the board

Also funny the thermistor for the hotend is also an issue, as that’s on a separate toolhead board

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.