Heater extruder not heating at expected rate - another one

I am having a problem with a print failing with “Heater extruder not heating at expected rate” at the same point in the print. I have done a PID calibration with no luck. Checked that the part cooling fan does not effect the temperature. Resliced the file with the print stopping at the same point. Because it happens at the same space, I don’t think it is an intermitted hardware problem. I have resliced the file with the same results. I also sliced it with Cura (used PrusaSlicer originally) and got the same results. While the location the print failed at changed, it still occurs at the same place each time I run the file.

I have tried changing layer height, print speed, and turning off pressure advanced (was getting an internal error on G1). I don’t know what else to try. Because of this, I can’t get anything to print that is over an hour or two.

I have some log files from when it was failing but doesn’t look like I can post it with the message. I can try putting them out on Google Drive if needed.

Here is a link to one of the log files: klippy (3).log - Google Drive

This appears to be a hardware issue. Your hotend cools down from 215 to 207.8 over a fairly short period of time even though the heater is at 100% duty cycle. I would assume this coincides with the part fan turning on. Try insulating your heater block.

extruder: target=215 temp=207.8 pwm=1.000
Heater extruder not heating at expected rate
Transition to shutdown state: Heater extruder not heating at expected rate

I should also note your hotend heater is running close to full power just to maintain a temperature of 215 throughout the log. This would indicate you might have a failing heater cartridge, or perhaps some air from your hotend cooling fan is reaching the heater block. It shouldn’t require full power to maintain 215C on a hotend.

1 Like

I have a new hotend coming, but I don’t think that is the problem. The fact that the error occurs at the same place on the prints, and not based on time, it doesn’t appear to me to be a hardware issue. On the github, another use noted having the same issue. My understanding is they found klipper was not turning on the power even though it says it has. So seeing the 100% in the log doesn’t mean the power is actually being turned on.

As for the part cooling fan cooling the hotend, I tested that first thing and it is not an issue. I had the hotend up to 245 and turn the fan on to 100%. There was only a small drop of a couple tenths of a degree before it was back up to temperature. And the error was occurring on the 3rd layer after the fan has already been on for all the second layer and there was no fluctuation of the temperature.

And I do have a silicon sock on the hot end.