Help with RPi Zero 2w UART connection

Basic Information:

Printer Model: ender 3 Pro
MCU / Printerboard: creality 4.2 7
Host / SBC : Host (aarch64, 64bit) OS: Debian GNU/Linux 12 (bookworm) RPi Zero 2w
klippy.log : attached

klippy.log (509.3 KB)


Hi

I tried to use Klipper on my Ender 3 Pro connection over UART I do everything but I am Unable to connect to MCU :upside_down_face: :smiling_face_with_tear:

[mcu]
serial: /dev/ttyAMA0 # For UART Connection
# serial: /dev/serial/by-path/platform-3f980000.usb-usb-0:1:1.0-port0  # USB Connection
restart_method: command

Screenshot 2024-05-06 135639

Screenshot 2024-05-06 135829

Screenshot 2024-05-06 140106

Note: I know I can use it over USB but I prefer to use this setup for compact size

Also, I followed this Klipper and the RPI-zero but It’s old, things have changed

What do I miss ?

Thanks

Before we get too far, Two very important things.

1.) Most importantly, are you sure the UART pins on your printer control board are 3.3V? Raspberry Pi’s are not 5v tolerant, you’ll kill your GPIO pins if you apply 5v to it.

2.) Are you sure your board has enough current to power the Pi Zero that way? The recommended power supply for the Pi Zero 2W is 5V/2.5A which I’d be very surprised if those two pins can put out.

1 Like

@TheFuzzyGiggler

1

You say a Step-Down module, are you pulling power from the power input of the controller board or from the pins in the diagram?

And this is me just kind of nitpicking, so take it with a grain of salt cause it’s your setup not mine… All this is easier than just using a usb cable?

But to get back on subject…

https://www.raspberrypi.com/documentation/computers/configuration.html#primary-uart

Primary UART
On the Raspberry Pi, one UART is selected to be present on GPIO 14 (transmit) and 15 (receive) - this is the primary UART. By default, this will also be the UART on which a Linux console may be present. Note that GPIO 14 is pin 8 on the GPIO header, while GPIO 15 is pin 10.
.

image

Primary UART on the Pi Zero 2 is

/dev/serial0

The one you have in your config is for the PL011 UART which is the secondary on the Pi Zero 2.

@TheFuzzyGiggler

what is your suggestion to modify config or other to get work ?

Try changing your config to this so it points to the right UART

[mcu]
serial: /dev/serial0
Connection
restart_method: command

Also, you might have some issues trying to use a Pi Zero for Klipper and a Webcam. I haven’t tried it myself but from what I’ve read it bogs down the system quite a bit.

Also be careful on your power draw if you try to use a webcam as well.

The Pi Zero 2 skirts the line on jusssst being powerful enough to possibly get away with it though.

finally back to USB