Unable to connect trough UART on creality board

Basic Information:

Printer Model: Ender 3 Max
MCU / Printerboard: Creality v4.2.2
klippy.log (95.2 KB)
Orange Pi PC plus + Armbian

Describe your issue:

Hi, since I have issues with communicating trough USB, so I tried to communicate trough UART. I’ve connected first 5 GPIO pins(5V, GND, TX, RX) to Ender’s LCD port (as told in default configuration). However it won’t connect and keeps saying “Disconnected”.
-All UART interfaces are allowed.
-Tried to swap RX/TX pins several times.
-Tried to replacing [mcu] Serial: property in config file with all serial ports available (from ttyS0 to ttyS7)

My questions are:
1 What should I try next?
2. Is it possible use UART on creality boards?
3. Can board make the difference? (for ex. Buy & use Raspberry pi 3B+ instead of Orangepi pc+)
4. Is it even possible to burn RX/TX pins or gpio by just swapping them?

Fixed it by replacing Orange Pi PC+ for Raspberry pi 3B+ and started using USB connection again. No EMI USB hub and klipper shutdowns anymore.