Mcu Unable to connect Creality silent board

Basic Information:

Printer Model: Ender 5 PLus
MCU / Printerboard: Creality Silent Board
klippy (2).log (132.0 KB)


Fill out above information and in all cases attach your klippy.log file. Pasting your printer.cfg is not needed
When pasting code or config snippets use the code tags </> in the menu above

Describe your issue: Im stuck here I cant figure out why it cant find the MCU but when I run it on Rasberry PI it can find the MCU. I have the 2.2 Silent board and IDK what next steps i should take to solve this

Having this exact same issue and cant find any information about it.

  • Repeat flashing the board. Make sure to compile for AVR atmega2560 with rest as default in make menuconfig
  • Check with ls /dev/serial/by-id/* for the presence of the serial and compare with your cfg setting
  • Check powers and cables

Thank you. I can still see the /dev/serial/by-id/* and it shows up the same as it did before flashing the board. The only other thing i have found is about flashing the screen. Could the screen on the Ender 5 Plus be causing it to no connect?

Don’t know. Try it. I do not use displays on my printers and I also do not know what kind of display you have, how it is connected and if it is even supported by Klipper (Displays are not exactly Klipper’s strong side).

Ok i will give that a shot. Its just the stock display. Thank you for the help!

Could you solve the problem?I read that Creality V2.2 silent boards are not compatible with klipper since their tmc2208 drivers doesnt have uart connection.Can i run klipper on my v2.2 silent board?I found a tutorial video about the klipper installation to stock mainboards,but it says it doesnt work anymore.What is the cause of this to not to work?Due to stock touchscreen?If it is i have an oppurtunity to not use it.Please inform me about this topic.I stuck