Internal error on G1" stepcompress error

Basic Information:

Printer Model: voron 2.4
MCU / Printerboard: btt octopus/ raspi 3b
klippy(14).log (6.4 MB)

Fill out above information and in all cases attach your klippy.log file. Pasting your printer.cfg is not needed

Describe your issue:

…I’ve had a big problem on my voron 2.4 running klipper mainsail where everytime after it prints for 4 or so hours it shuts down with “internal error on G1” and in klippy.log it says something along the lines of step compress error. This issue has been plaguing me after multiple reinstalls and hardware changes.

There are quite a few
Transition to shutdown state: Lost communication with MCU 'mcu'
errors in your log, which point to a general hardware instability. See Timeout with MCU / Lost communication with MCU

so this could mean a bad raspi or cable?

I’ve gone through all my wiring even gotten a new USB c cable and the error still continues to happen. Can you help me diagnose whats wrong?

The known causes of such a timeout error are listed in the linked post above (which is more than just changing the USB cable).

In addition, I see two points for troubleshooting:

  • Your configuration is very complex: I’d reduce it to the minimum needed for printing and see if the errors still occur.
  • You are using a modified version of Klipper. Go back to the original mainline Klipper and test again.

what do you mean by modified version of klipper and how do i go back to the original?

Git version: ‘v0.11.0-240-g6d48adf9-dirty’
Untracked files: klippy/extras/

1 Like

what does this tell you? also this error has happened before i installed z_calibration

It indicates that you have z_calibration installed which is not a mainline Klipper module. The developers generally won’t investigate errors like this when you’re running code from someone else.

1 Like

I’ve removed the modified files from klipper and got the same error
klippy(18).log (3.6 MB)

That’s odd. Can you also compress and attach the gcode file that you were printing at the time of the failure?


Sorry for the late response. I am unable to pinpoint where in the gcode file where the error occurred but it happened somewhere around 1 hour and 15 minutes in but this was the most recent file i printed where this error occured
contact sleeve.gcode (915.2 KB)

i’ve also changed my MCU and ras pi and this error still happens

sorry to keep on replying but i’d really like to get some help on this error. I’m going to college on wednesday and won’t have my printer with me for several months

I looked through the logs again, and also ran a simulation of the print from that file. I was not able to reproduce the failure (simulating the print succeeds without issue). Unfortunately, that means I don’t have any leads on what the root cause of the problem is.

These types of failures are very rare. It’s possible (although unlikely) that there is some kind of corruption of the code or OS. You could try a full reinstall of the host machine and reflash of the micro-controllers.

Otherwise, if the problem persists, the only advice I can give is to gather more information. (For example, see if there is a pattern on failures, check if the same prints always fail at the same time, and similar.)


Thank you for looking into the issue though unfortunately i moved into my college dorm and am unable to access my printer until december. for information regarding the problem i’ve done multiple reinstalls of klipper on multiple different boards and the prints typically are failing at the same time give or take 5-10 minutes

am back from college for break, I have once again reinstalled klipper and have updated all dependents yet I still get the exact same error at a similar time interval of printing
klippy(19).log (956.6 KB)

That log does not show an error.


whoops for some reason that log didn’t show the error, this one should. I noticed that when i reposition my mcu cooling fans to be more direct with the mcu i was able to get a 2 hour print done before it shuts down to the same error. could over heating have something to do with the error?
klippy(21).log (6.0 MB)

Your log shows:

Git version: 'v0.12.0-32-gf0753bd3'

which suggests that you have not updated to current git and thus do not run the fixed version.