Klipper expander board Issue

Basic Information:

Printer Model: Mercury ONE.1
MCU / Printerboard: SKR Mini E3
klippy.logklippy (9).log (715.1 KB)

Hi all!!!

I finally installed the Klipper expander board as I need the extra mosfets for my cabon filters.
I Followed the manual here: Voron-Hardware/Klipper_Expander/Documentation/Setup_and_Flashing_Guide.md at master · VoronDesign/Voron-Hardware · GitHub

However. Upon adding the KlipperExpander.cfg and included it in Pinter.cfg I get the following error message:

Klipper reports: ERROR

Unknown pin chip name ‘expander’

Once the underlying issue is corrected, use the “RESTART”
command to reload the config and restart the host software.
Printer is halted

which is strange as I copied the klipperexpander.cfg and only altered the serial in row 4.

Is there someone that know whats going on here?

You seem to have omitted the last step in the guide:

Your board should now be usable with Klipper. Use the example config file to get started Best option is to copy the example config file into the same directory as printer.cfg then add [include klipperExpander.cfg] to the end of your printer.cfg to include the file.

There is no trace of a correctly configured

[mcu expander]
serial: /dev/serial/by-id/usb-Klipper_stm32f042x6_350022000D43504735393520-if00
restart_method: command
1 Like

Thanks for looking into this.
I dont understand or I am missing something.

I added the klipperexpander.cfg file in the same directory as printer.cfg.

In printer.cfg i added [include klipperExpander.cfg]

Post both your printer.cfg and klipperExpander.cfg

1 Like

config-20240218-175122.zip (2.6 KB)

see attached :slight_smile:

In klipperExpander.cfg:

serial: /dev/serial/by-id/usb-Klipper_stm32f042x6_040024000C43303054313620-if00 
restart_method: command

needs to be (as also required in the example config):

[mcu expander]
serial: /dev/serial/by-id/usb-Klipper_stm32f042x6_040024000C43303054313620-if00 
restart_method: command

Verify that this is actually correct and your expander board is flashed with the correct settings

managed to make it work!

Indeed the following error was: [mcu] instead of [mcu expander].
Changed it. Klipper is now recognizing it!

Thanks for the insight!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.