Klipper update problem

Forgive me for my very bad English google translation.

I just updated:

  • fluidd: v1.18.1
  • klipper: v0.10.0-448-g9047702a
  • moonraker: v0.7.1-573-g74d6e35

Hardware configuration:
Creality ender 3

  • mcu: creality 4.2.7
  • Bltouch
  • extruder: biqu H2
  • End of filament detector

Problem :
Since the update on all of my new prints, I have a shift on the Z axis during printing when moving my nozzle on the X axis on the 1st layer, which forms a kind of arc for me. circle on the Z axis (example distance: x:10 y:100 z:2 - x:100
y:100 z:0 - x:200
y:100 z:2)

Consequence: Part of the one if it sticks well to the board (the center of my parts on the contour) and on the outside of my X axis part it doesn’t at all stick to the board.

In addition the filling is the same I have a Z axis rise ~2mm I stopped at the 1st layer because it is the base if the base is not solid the result will be a disaster.

All my prints start with a G29

Has anyone else had a problem? is this a firmware issue?

Having made no other modification than an update, I do not see where the problem would be.

I enclose my config file sometimes it is to ask me in .txt of course it goes without saying that they are .cfg

other.txt (1.6 KB)
printer.txt (1.7 KB)

an upload file limit by msg I create an additional response for these files

macros.txt (2.2 KB)

it seems that you fake the log file I allow myself to add it to you.
Afterwards I may be the only one to have this default
klippy.log (793.2 KB)

I would like to change the subject of the post because no one seems to understand

I have a shift on the Z axis during printing when moving my nozzle on the X axis on the 1st layer

Your build plate may be warped. I’ve experienced this several times on the Ender 3 using the stock Creality spring steel build plates. Klipper can correct for this using a bed mesh. Try running BED_MESH_CALIBRATE and see if that helps.



You will have to add a [bed_mesh] section to your printer.cfg file. This should work for the Ender 3.

speed: 120
horizontal_move_z: 5
mesh_min: 15, 15
mesh_max: 220, 220
probe_count: 5, 5

I already have a bltouch installer, all worked perfectly before the update

@nda is right. This is almost certain (99.9873%) not a software issue but either your bed leveling or Z-Offset is off.

max_extrude_only_distance = 100.0
rotation_distance = 23.
gear_ratio = 32:16, 56:16
  • max_extrude_only_distance is only “needed” if you are doing something strange
  • rotation_distance = 23. having straight 23 looks like the extrusion is not tuned. See Rotation distance - Klipper documentation
  • gear_ratio = 32:16, 56:16 → Does this extruder really have two different gear conversions?

I am with the biqu h2 I have collected information on people from klipper who uses this extruder it worked before the update without worry I will reinstall and see what it gives me.

finally for the bed the bltouch makes me all the tray at each start of printing.

I see that you tell me to go to the side of the bltouch to see in installing things that have already been done.
now you’re telling me it’s probably at the extruder.

Am I formulating my problem incorrectly?

Maybe am formulating my answer incorrectly. Please allow me to try again

  • Your bed leveling is bad OR
  • Your extrusion system is messed up OR
  • Both

Check and fix it.

what I tell you is that everything worked perfectly before the update the bed did not change and my extruder either the config was perfect
and after the update ba a problem appeared the one that I told you between 2 I did not change anything

I just went from fluidd to mainsail to test the same problem I do the leveling of the bed well at each start of printing, however we would say that it does not remember its palpation and gives me the same shift, even the nozzle goes up on the Z axis on the dimensions as explained above

From the image you posted above you have either a Z-Offset, Leveling or Extrusion problem. IMO completely unrelated to any Klipper update.

Cannot offer any more advice than posted above already.