Klippy.log updates not while idle

Hi all,

I wonder when the klippy.log file is updated with the readings from the printer and when not?

I have a problem with my extruder temperature. During some prints I get the “Heater extruder not heating at expected rate” error. This happens now 3 times with the same gcode and once with a slightly changed gcode file. With test prints I don’t get it but they may be too short. Also the error seems to happen always at the same location of bed (X/Y position). So I figured it might be the cabling to the sensor but didn’t see any loose or damaged parts at the hotend or the cable and its sockets.

So I downloaded the klippy.log file and displayed the extruder temperature over time using a jupyter script. There I see that the extruder temp jumpes from 200°C to 110°C from one entry to the next. Then there is another entry at this temperature and then it jumpes back to 200°C. see:

So Its obviously not a physical problem but a signal problem (broken wires not counting at physical for now) since there is no way the temperature can drop/increase that much.

Also I do have problems connecting to the printer with klipper from the raspi sometimes. Then I turn off/on the printer and it usually works fine. So I wanted to check the connection stability.
Therefore, I checked the klippy file over time but it appears that the entries are not continous.

How can I assure that the klippy file is updated continously even when not printing? Is this a normal behaviour?

All Best,

PS: printer is anycubic chiron, klipper on raspberry pi 4

There seems to be a communication problem. I just heated to 200°C without moving anything. After 10min the temp was set to zero again (not sure but seems to be absolutely an understandable safety feature). During the cool down phase I saw a dip in the extruder temperature in octoprint which reads the temps constantly with an M105.
Just at that dip, the klippy.log file stopped being updated.
Is there another log that I can check?

Update2: Also now it says the motors were not homed, but I did home them before heating up the extruder.

I did the same heating to 200°C as shown above and get again the dip in the cooldown phase at 50°C.

Here is what I get from the klippy.log file for both events:

In the second test I set the target temp to zero by hand before 10min were over.
(I can only add one picture per post so far).

Do you have HeaterTimeout installed in OctoPrint?

Hi. Yes, I have BetterHeaterTimout and that was what caused the Temperature to go down after 10 min. Also I asked in the discord channel and @zGrozemaG told me:

not logging temperature on idle printer is normal, as no module uses that thermistor below 50C (you likely have hotend fan that uses it up to that point)
and your motor issue is likely just [idle_timeout] module doing its work, or your octoprint (usure on how octo does stuff nowdays

He was right with both. So I will disable the BetterHeaterTimout and repeat the test tomorrow. I want to see if it is stable over time.

1 Like