Layer shift after new MB and Klipper

Basic Information:

Printer Model: Raptor 2 Modified to 800 on y-axis
BIQU Manta M8P v2.0 with CB1 and SB2209
klippy.log

Describe your issue:

klippy.log (3.4 MB)

I’m having a problem with layer shift since I upgrade the motherboard I added a second stepper to the y-axis to see if it would help, but it didn’t. It is always the same layers that shift, now I wonder if it something in the gcode.


VR20_Sizzling Bojo-Amur (3).gcode (1.5 MB)

So this is a bedslinger with a 400x800 bed? If that’s correct I would suggest trying lower acceleration values. As you build layers the bed is getting heavier, and you might simply be reaching the limits of the stepper drivers and/or motors.

I didn’t have this problem before I changed the original MB running Marlin with the same bed and only one stepper for the bed.

I just added an extra stepper, I now have one in each end, both 60mm 2.1 amp.

I tought it maybe be something in the printer.cfg or in the gcode, since it always happens at the beginning and in the end of the print.

I like this statement. It basically goes: I turned my printer into something completely different and now it has issues.

As @jakep_82 pointed out, it could be:

  • Insufficient torque
  • Stepper driver and / or motor getting too hot
1 Like

No, I changed the MB and installed Klipper and now i have issues.

Even with one stepper it never got warmer then you could comfortably put you hand on it and hold it.

It has two steppers on now that is double the torque as before with Marlin and the old MB.

It have to be something that I did when I installed Klipper, maybe the printer.cfg.

The only thing else I have changed is the Linear Bearing Carriage from medium preload to zero preload, maybe it need that preload?

When I search it always say, use zero preload for 3D printers that is the reason I changed them.

1 Like

When I see this in [stepper_Y] and [stepper_y1]

run_current = 2.1
hold_current = 1.0

It is obvious why you have layer shifts.

The difference is way to much.

You may do without hold_current:

https://www.klipper3d.org/TMC_Drivers.html#prefer-to-not-specify-a-hold_current

Also:

Are you 100% sure about this:

sense_resistor = 0.033

TMC5160 usually are ratet with 0.075 Ohm sense resistors.

2 Likes

Thanks, my first try with Klipper, I will try your suggestion.
The setting was from the default printer.cfg, I now see others havimg it set to 0.075.

Thanks again, will try it and let you know.

1 Like

I removed hold _current and changed the sense_resistor to 0.075.
Then I started printing and everything looked good for the first 30 layers and I went to sleep, next morning I had this.

It looks like after 30 something layers it shifted for every layer after.

The only thing I can think of is that I will have to sit and watch the whole print to see if i can see why it shift.

As i remove the print I found that the belt had come loose. I will fix it and try another print.

2 Likes

Here what happen, the bracket I had made for the second Y and printed in PETG had melted. I removed the second stepper and are now printing with one stepper.
I was wondering if the run_current is to high, the steppers are rated to 2.1 amps and I have the run_current set to 1.9 should lower it?

You can see the impression of the stepper in the bracket.

1 Like

I run on 1.15 A on X and Y and 1.2 on Z (Dual Z) With nema 17 steppers and TMC 2209

Thanks, I will try that setting.
The new print It’s now 78% finish and i haven’t had one single layer shift, look good.

2 Likes

That is way too high as you can see!
Maybe this link can help you find a better current value:

However if a stepper motor is too hot to touch the current is normally too high!
And if your stepper drivers are not cooled they might die as well.

1 Like

The print came out perfect, with one stepper on the Y, thanks for your help.

2 Likes

According to this link, the run_current should be set to 0.8 (2.1 / 0.707 = 0.8484) for 2209 drivers.

BIQU tech told me anything from 1.2 to 2.1 for 5160 drivers, that is why I have it on 1.9

I will give it a try, thanks.

1 Like

You got the calculation wrong. It is

run_current = rated_current / sqrt(2) = rated_current / 1.414

OR

run_current = rated_current * (1 / sqrt(2)) = rated_current * 0.707

My advice is to take around 80% of this, since you do not want to run your stepper at it’s max due to heat.

So for your stepper:

run_current = 2.1 * 0.707 * 0.8 = 1.18

Edit:

  • You can go up to 100% → 1,48 depending on the heat the stepper develops
  • It does not depend on the driver, i.e. the same applies to TMC2209 as well as TMC5160
2 Likes

Thanks, I will try 1.2 and check the heat.

1 Like