MCU error. Will not load. Errno 2

Basic Information:

Printer Model: sp5 v3
MCU / Printerboard:Robin Nano v3.1
klippy.log (490.3 KB)


Fill out above information and in all cases attach your klippy.log file (use zip to compress it, if too big). Pasting your printer.cfg is not needed
Be sure to check our “Knowledge Base” Category first. Most relevant items, e.g. error messages, are covered there

Describe your issue:

For the life of my I can not get the mcu to be recognized. I’ve done the steps to fix the serial/by-id/* issue but that didn’t solve the problem. I’ve tried 4 different USB cables but that doesn’t seem to work. It worked once and i tried to home the machine and it jolted a little bit then stopped. changed the current on the steppers saved and restarted and it never came back up. Have tried the original printer.cfg i had before i modified the current values. I’m at a loss at the moment. Any help would be appreciated

What do you think what <your-mcu-id> means?


You noticed this at line 11588?

serial = /dev/serial/by-id/usb-Klipper_stm32f407xx_480030000150305148383820-if00

Ah OK my dump was too short, sorry.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.