MCU lost communication - SKR v1.3 - klipper 0.10

Hi guys, another brick in the wall :slight_smile: lol… meaning i have seen several problems like this in the reports, already replaced the USB cable, put a decent 3A power supply on my RPi4 and still get random errors of “MCU lost communication” I wonder why…
I had klipper 0.8 before running on my machine with a SKR v1.3 with 4 TMC2208 for XYZZ and a TMC2209 for Extruder and a Fysetc 12864 RGB working with no issues as I recall. Seen the version 0.10 available and immediately want that input shaper resonance on my machine as well so I upgraded to FIRMWARE_VERSION:v0.10.0-106-gffeafb69 FIRMWARE_NAME:Klipper
and started some problems with the 3D printer having some stalls at random positions… sometimes it prints for 2 days without any issues, sometimes after 1 hour or so it stops due to MCU lost communication.
Is there any other reason so I shouldn’t have upgraded? I converted the printer.cfg params like rotation_distance and tried to not touch it further because everything was running smooth.
How do I find the golden key to overcome this issue?
I upload my klippy.log in a zip file because it was a bit over the 4MB maximum size so someone can help me out with this? Sorry to had zipped the file but was the most convenient way I figured out

Thanks ahead
Vasco (1.2 MB)

Just forgot to say one very important thing… When It looses connection… it may be in the board something staling because I get a blank screen when I reach the 3d Printer… so, i think the BOARD crashed or something like that. How can I figure out?

Many thanks!