Mcu problem / printer not ready


I am trying to config Klipper on SKR 1.4 board.
I went thru the config. Fluid is installed on my Raspeberry Pi. I compiled and flashed the firmware on my board. Yet it keeps showing “Printer is not ready” and “mcu ‘mcu’: Unable to connect”.

When I check if the board is connected to the Pi with “ls /dev/serial/by-id/*”,
I get “serial: /dev/serial/by-id/usb-Klipper_lpc1768_05E0FF01809C48AF441F3A5DC62000F5-if00lpc”
So I tried to input this in my printer.cfg but my klippy.log keeps showing the mcu being “serial = /dev/serial/by-id/usb-1a86_USB_Serial-if00-port0”
When I tried to untick the USB during compilation of the firmware. I am not able to get anything in the serial request.
When I input the serial that klippy.log gives me. nothing changes…

Here is klippy.log (225.9 KB)

can someone guide me?

Thank you


It looks like you chose the wrong board type during make menuconfig. SKR 1.4 has a LPC1769 chip.


thank you for the reply.
Unfortunately, it is not the problem since my board is a non-turbo one.
SKR 1.4 has a LPC1768 chip and the SKR 1.4 turbo has a LPC1769 chip.

Yes, sorry, of course you are right.

This basically looks correct. Sometimes a board is not correctly flashed. Try repeating the flashing process.
What strikes me a bit strange is -if00lpc ending. Typically it looks like
/dev/serial/by-id/usb-Klipper_lpc1769_0C70001625813AAF86E06B5CC32000F5-if00 → just if00 without the lpc

Thank you!
I double checked today the “ls /dev/serial/by-id/*” and there was no lpc at the end. So I removed it from the printer.cfg and it stopped showing me the “printer is not ready” error.
Thank you!