Mcu 'rpi': Unable to connect

Basic Information:

Printer Model: Kingroon KP3s
MCU / Printerboard: Robin Nano
klippy.lo [klippy.log|attachment](upload://nL2hblu3Sv8dTzQmQwcUrPftSir.log) (100.0 KB) g
So, I had Klipper up and running with no issues after a long slog with the initial installation. Then, it appears, the micro sd card in my Pi died. No problem, I have a backup. Pi starts and runs, mainsail loads, however it spits out the error “mcu ‘rpi’: Unable to connect”. I’ve tried everything I know how to do. I even reflashed the printer firmware, created a new sd with Mainsail/Klpper, updated everything, etc. Used my backup printer.cfg and it loads without errors.

I’ve tried this on two Pis and with two different printer cables. Any help very much appreciated – I’m going crazy.

Describe your issue:

If you’re using your Pi as a secondary MCU you need to reinstall and flash if you created a new installation on a new SD.

I’ve been able to – a few times now – burn a SD with the Mainsail/Klipper package, use the same .bin file and printer.cfg file and get everything working without generating new firmware and it worked just fine. Then, on a working setup, this message appears after the SD failed and another working SD was inserted into the Pi. In other words, the combo that is now failing worked before. Something somewhere has changed. Anyway, I did go into Klipper and create a new firmware file, flashed it to the printer and I’m getting the same error.

If you’re using your Pi as a secondary MCU, you need to follow all the steps in the link I posted when setting up a new SD card. I’m not talking about flashing the controller board. You need to install the rc script, and flash the binary for a Linux MCU. Without a log file I can’t offer any more help.