Moonraker not connecting to Klipper

Basic Information:

Printer Model: Kingroon KP3S
MCU / Printerboard:MKS Robin_Nano v1.3

I am trying to install Klipper on a Kingroon KP3S with the Robin_Nano v1.3 board. I have followed the steps in the first two “How to install Klipper, the easy way using Kiauh” video’s but when I try to “get mcu ID” in Putty I get " usb-1a86_USB_Serial-if00-port0 " and when I go to Mainsail and hit “firmware restart” I get " mcu ‘mcu’: Unable to connect ". Mainsail also says that Moonraker can not connect to Klipper. USB cables are good. I am new all this and so any suggestions or advice would be much appreciated.

klippy (1).log (28.5 KB)

Your printer.cfg is not complete, i.e. the [mcu] section is wrong. Follow configuring-klipper

Thanks very much, that really helped and I seem to be connected now but I seem to have another problem that I haven’t seen mentioned anywhere else. When I bring up Mainsail I don’t get what I believe should be the default screen. Instead I get a box in the upper left corner with " status, files and job queue in it and ERROR in the top left corner of that box. Below is the macros box and to the right side of the screen is console box. This does not look like any default screen I have seen. Again thanks for the help with my first problem and if you have any thoughts on this one it would be appreciated.


Could you upload a screen shot of what you are experiencing? I think I know what you are talking about, but I am not sure. A visual sure would help.

Hope This Helps,

This is what I’m getting.


Did you try to start a print? Or did you just turn on power without doing anything else and you got this.

Hope This Helps,

I just turned the power on and got this. I’m not even sure how I would start a print from here.

Post a new klippy.log. Your configuration is faulty / incomplete

Here you go, also could you suggest a source so I can start learning some of this stuff myself or is it a kind of learn as you go?

klippy (2).log (254.1 KB)

Apart from the “standard macros” that are recommended by the webinterface, your printer.cfg does not contain the faintest trace of a printer configuration.

I strongly propose to follow the official Klipper Documentation.

In a nutshell: You need to amend your printer.cfg with the configuration of your printer. Refer to klipper/printer-kingroon-kp3s-2020.cfg at master · Klipper3d/klipper · GitHub