Cannot get Klipper to connect to my new Kingroon KP5L

Basic Information:

Printer Model: Kingroon KP5L
MCU / Printerboard: Standard, whatever that is.
klippy (6).log (43.9 KB)


Describe your issue:

…I have an Asus laptop that I have installed Raspberrypi Desktop onto.
I used KIAUH to install 3 instances of Klipper and Moonraker and Installed Mainsail.
I used KIAUH to check MCU id and it returned with ttyS0
I flashed a .bin file to the printer and the screen has gone.
Downloaded and followed the instructions on the Kingroon GitHub to build my firmware after copying the printer.cfg file.
I’m almost certain it has something to do with identifying the serial port for the mcu but I have tried so many variations and haven’t had any luck.
I did at one stage try a mks robin nano printer config and at one stage it did connect but only the z axis would homw correctly. Thats when i hunted around for a better printer.cfg file but after changing to that, I haven’t been able to conect again.
Please help me beat this thing, I’m going crazy. I’ve been trying to nut this out for the last 6 days. Brand new to linux so it’s been a steep learning curve for an old fella.

This seems all a bit confusing:

Why do you install a Raspberry specific Linux on a Asus Laptop?

Why do you install 3 instances?

What is the output of ls /dev/serial/by-id/* (execute in a Linux shell)

Sorry for the late response, I posted this just before I headed to bed.
I have installed it on an old laptop that I had because I didn’t want to buy 3 Raspberry pi’s.
I installed 3 instances of klipper because I want to be able to control my Kingroon kp5l, and Ender3 and an Ender3 Pro.
I cannot get a response from that command. It just tells me ls: cannot access. No such file or directory.
From the KIAUH install screen I did a mcu search and it told me that it’s ttyS0, but I’m not sure if I’m typing that into my printer.cfg correctly. I have tried typing it several different ways but I cannot get it to connect.

I would not recommend to install a ARM architecture optimized distribution on a general purpose machine. Although it should work, I’d not take the chances. There is a reason why there are different Linux distributions with different targets.

Might make sense to go step by step, especially if you are a beginner.

Check Debian Bullseye Bug causing Klipper to no longer find the printer board

Firstly I tried to install Linux mint, it installed fine but I had no screen after it installed. Apparently the Nvidia on my laptop causes that issue. I then tried Ubuntu and it seemed fine until I rebooted it and lost the screen on that also. Someone recommended trying raspberrypi for desktop as it is very lite. It installed easily, had the screen and reboots fine.
I then used the KIAUH install helper to install klipper, moonraker and mainsail. This all went without a hitch except for connecting.
What should I see when I type in ls on its own. I don’t think things are in the right place.

How old is that laptop? Or better: What laptop exactly?


It’s an Asus K53s. I have no idea how to find the specs on it now that it has raspberry pi desktop installed. As you can probably tell I’ve been a windows user all my life and never touched on Linux before. All I know now is that it has an Intel core i5 processor and a Nvidia geforce GT 520M installed. Original operating system was windows 7. Had been upgraded to windows 10 before wiping it.
I didn’t get my guidance from Reddit, I had been chatting with a guy on the Kingroon Facebook page that is running his printer on Klipper and when I explained about the loss of screen , he suggested I try raspberrypi for desktop so I gave it a try and it installed fine and I had a screen again.

It’s really difficult to get decent information on this on. It’s about 100 years old.

I have an HP laptop from that time that runs fine with Ubuntu 22.04 LTS and OctoPrint.


I assume he meant this:

That should be no problem.

You have checked the serial?

serial = /dev/serial/by-id/ttyS0

Just tried typing in that command and I got

bash: serial: command not found

What should I expect to see if I type. ls at the command prompt?

It should be like its described here:

Otherwise, the following steps are often used to “flash” the printer control board. First, it is necessary to determine the serial port connected to the micro-controller. Run the following:

ls /dev/serial/by-id/*

It should report something similar to the following:


I assume you need an USB driver for the RaspberryPi OS

Yes, Did the identify MCU on KIAUH and it told me it was ttyS0

Strange it does not appear in the folder

I’ve searched for it every way I can think of hoping it may just be in the wrong area but can’t find it anywhere. Stupid thing is I got it to connect once or I would believe that it ever would.

Did you try

I’m unsure if you tried.

I’m also an old dos/windows user and started using Linux maybe 5 (maybe more, but still in the learning curve) years ago. Good thing with Linux, you can google everything, if you need help (much better documented than dos/windows). For example, in your terminal with Linux, you punch in the terminal window.

ls --help

You will get all options, you may use with that command (works with almost every Linux command).

ls is corresponding to dir with dos/windows.

Another thing with Linux is “who has the rights”. If your command in your terminal fails, try “sudo” (superuser) in front of your command. Please google it, before you use it (can be dangerous).

And please don’t post screenshots/photos of your terminal (very hard to read). Please copy and past the output, when you reply.

One thing I forgot, I’m using Xubuntu. In my eyes the most similar “look” compared to windows.

Good luck, hcet14

1 Like

OK, I started over and tried installing Ubuntu server instead of desktop. Everything went well, klipper installed, moonraker installed and mainsail installed. Rebuilt and reflashed the board with the firmware.bin file. I can now ssh into the server ok, I can now see the mainsail interface on my PC. My server is now connecting to my printer but it will not home or move any of the axis. I get this error.
Unable to read tmc uart ‘stepper_x’ register IFCNT
Once the underlying issue is corrected, use the
“FIRMWARE_RESTART” command to reset the firmware, reload the
config, and restart the host software.
Printer is shutdown

Check the UART wiring of the X stepper driver. Klipper lost contact to the TMC.

This printer is almost brand new, all the wiring looks fine. It worked fine with Marlin so I’m sure there is nothing wrong with the printer. Now that I finally have Klipper connecting to the printer it seems that its a configuration problem, like the pin allocations for the steppers are incorrect.
I have used the printer.cfg file from the Kingroon Github and followed their flashing instructions but I don’t know if their printers use the same boards and stepper drivers in all builds.