Raspi 4 failing to make usb connection to MCU

Basic Information:

Printer Model: Ender 3 Pro
MCU / Printerboard: SKR mini e3V3

Ive been attempting to get Klipper setup on my Ender 3 for a few hours, and for some reason, I cant detect any usb connection even though it worked perfectly fine for Marlin. Im out of ideas as to what the problem is, I didnt have much knowledge in the first place, and I would greatly appreciate any kind of help.

klippy.log (36.8 KB)

serial = /dev/serial/by-id/<your-mcu-id>

Most likely <your-mcu-id> is not your mcu id.
Follow Installation - Klipper documentation and verify your firmware settings and config against klipper/printer-creality-ender3pro-2020.cfg at master · Klipper3d/klipper · GitHub

I’m having issues finding the MCU. I’ve tried running " ls dev/serial/by-id * " to locate my MCU id, but it says the directory cannot be found. I’ve also attempted to run all of the fixes you suggested in this thread :

But I’m still unable to detect a connection.

It looks like your board is flash with the wrong settings. As stated above, closely follow the instructions on top of klipper/printer-creality-ender3pro-2020.cfg at master · Klipper3d/klipper · GitHub

Also make sure to mind the difference between a STM and GD chip

Ah, sorry, my fault. You need to follow klipper/generic-bigtreetech-skr-mini-e3-v3.0.cfg at master · Klipper3d/klipper · GitHub

Also post the output of sudo dmesg after disconnecting and reconnecting the board

new 2.txt (31.0 KB)

I tried to re-flash everything and start fresh. I set everything up using the github link you provided and YouMakeTech’s tutorial for installing Klipper (pictured in my screenshot) onto the board I have, but my pi still doesnt seem to be able to detect any usb copnnection. Also the “new 2” attachment is the result of me running sudo dmesg.

From your log:

[    2.262662] usb 1-1.1: new full-speed USB device number 3 using xhci_hcd
[    2.374329] usb 1-1.1: New USB device found, idVendor=1d50, idProduct=614e, bcdDevice= 1.00
[    2.374376] usb 1-1.1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[    2.374394] usb 1-1.1: Product: stm32g0b1xx
[    2.374420] usb 1-1.1: Manufacturer: Klipper
[    2.374445] usb 1-1.1: SerialNumber: 4C00230016504B5735313920

This looks good. ls /dev/serial/by-id/* should return the correct path for your config

Still no dice.
ls /dev/serial/by-id/* brings this back

Check Ender 3 S1 - No USB ID - #5 by Gre3k
Maybe you are affected as well.

That did something. Im not sure what to do from here though

Reboot, try again, although it does not seem that the command worked correctly

Its still coming up with this menu(?) and it still cant find the usb

Copy and paste as formatted text (</> symbol in the menu here) the output of
apt-cache policy udev

1 Like
  Installed: 247.3-7+deb11u2
  Candidate: 247.3-7+deb11u2
  Version table:
 *** 247.3-7+deb11u2 500
        500 http://deb.debian.org/debian bullseye/main arm64 Packages
        100 /var/lib/dpkg/status

Yeah, looks like you are affected by the Debian bug:

Try following approach

  1. Execute sudo apt edit-sources
  2. In the editor that opens (if asked choose nano) add following lines at the end:
    deb http://ftp.debian.org/debian bullseye-backports main non-free contrib
  3. Save and close
  4. Run: sudo apt update
  5. Run: sudo apt install udev -t bullseye-backports
  6. Reboot
  7. Try again
1 Like

Eureka, I think you’ve done it.

1 Like

Hey @Sineos

I saw your announcement on this but I can’t reply to it.

First off, I’m NOT having any problems at all. I’m running 64bit OS on a Raspberry Pi 4B that is connected to an Octopus (STMF446) via USB that has CanBoot installed and is communicating with a Mellow FLY SHT42 via CAN. The rPi is running Mainsail and KlipperScreen with a BTT TVT5.0 UI attached.

When I run apt-cache policy udev in a machine that had its image created on April 22nd, I get:

  Installed: 247.3-7+rpi1+deb11u1
  Candidate: 247.3-7+rpi1+deb11u1
  Version table:
 *** 247.3-7+rpi1+deb11u1 500
        500 http://raspbian.raspberrypi.org/raspbian bullseye/main armhf Packages
        100 /var/lib/dpkg/status

For uname -a:

Linux freestyletest 6.1.21-v8+ #1642 SMP PREEMPT Mon Apr  3 17:24:16 BST 2023 aarch64 GNU/Linux

When I sudo apt edit-sources and look at it in nano, I see:

deb http://raspbian.raspberrypi.org/raspbian/ bullseye main contrib non-free rpi
# Uncomment line below then 'apt-get update' to enable 'apt-get source'
#deb-src http://raspbian.raspberrypi.org/raspbian/ bullseye main contrib non-free rpi

I currently don’t get anything with ls /dev/serial/by-id/* but I believe that’s due to having CanBoot installed and operational - correct?

The two differences I see are the “+rpi1” in the udev response and the commented out line in edit-sources looks quite close to what you are telling people to put in.

So, what exactly is happening here - do I have a problem? With the way things are working, it doesn’t seem like it.

Sorry for all the deleted posts, but i was continuing to correct some self inflicted issues as they arose. It looks like its working now, but i’ll update you if anything happens. Thank you a bunch for your help.

1 Like

You should get the serial device regardless if you have Canboot or not. I’m using Canboot on my board as well and I get a serial also.

The bug is officially confirmed by the Debian guys and has so far been fixed for Bullseye only as a so called backport.
The Debian backports have their own apt repositories and often need to be activated manually (as shown in my post) and also installing from the backport repositories needs to be called explicitly.

1 Like