Move out of range during bed_mesh_calibrate

ender3 v2
klippy (1).log (5.8 MB)

After i home the printer, ill complete auto bed leveling and then “move out of range” pops up. It altough comes when i just try to print something…

I have been reading a bit on forums now but i don’t know what values I should put in printer.cfg to fix this problem. have tried with different values for offset below [bltouch] but can’t figure it out

Thanks for the help

Hello @mt_ro !

You have a BLtouch offset of: x_offset = -40. (Left of the nozzle)
Your bed max-X is: position_max = 215
Your meh_max is: mesh_max = 215,215

To get the BLtouch to X = 215, the printhead has to move to 215 + 40 = 255.
That is the move out of range.

Move out of range: 255.000 15.000 5.000 [0.000]

Your max value for the mesh can be:

mesh_max = 215,175

Thank you so much, it did the trick. No problem so far anymore!

1 Like

so the problem does not come during bed mesh calibrate, but it comes when im trying to print, but whit new data. Quite new to this software calibratie so im working on the issue, but hope that you have an awnser for this issue aswell?

klippy (3).log (499.6 KB)

Add a position_min: -2 to the [stepper_z] section and also fix your slicer settings. It is emitting a lot of gcodes that Klipper does not use:

Unknown command:"M201"
Unknown command:"M203"
Unknown command:"M205"
Unknown command:"M205"
Unknown command:"M862.3"
Unknown command:"G29"
Invalid M204 command "M204 T2500 ; restore travel acceleration"

found a great video for this issue,

Hope if anyone else has the same issue thay can use this to get started whit klipper on new printer

ok, thx tho im not sure how to… ill see if i can fix it