Printer shuts down very early in to print

Basic Information:

Printer Model: Kingroon kp5l
MCU / Printerboard:standard
klippy (1).zip (370.5 KB)

Describe your issue:

Finally got klipper connecting to my printer and seeing files. I’ve been trying to do flow calibration but klipper shuts down 1/2 way up the cube. I can’t see anything in the klippy.log file indicating why it is shutting down.

See Timeout with MCU / Lost communication with MCU

Thanks for the reply, I’d already looked at those threads and checked what I could. Didn’t see anything wrong so just for shits and giggles, I sliced the same stl in Cura and the print finished perfectly. I will continue some more testing using Prusaslicer and Cura to see if it’s a consistent fail with one and not the other.
The only thing I can see that is different is that I had vase mode on with Prusaslicer and off in Cura.
I will turn it on in Cura and see if it finishes the print.

Slicers can do all sort of stupid things, but I have not seen a verified report that this kind of error is caused by a slicer.

Is there a way I can run the print file from an sd card instead of using the usb cable to eliminate whether it’s a cable/laptop issue or if it’s a printer board issue?

That will not work. Regardless where your gcode file is, Klipper needs a stable and reliable connection between board and host.

Ok, that makes sense. I’m just about to give up on klipper, I like everything I’ve seen of it so far but I just can’t get the set up I want. All I want to do is use an older laptop to install 3 instances of klipper, moonraker and use mainsail as my web interface. As this laptop will be sitting right beside my printers, I want to be able to see mainsail and control it from there.
Shouldn’t be hard right.
Tried Linux mint, couldn’t get a graphic interface, so it installed but I couldn’t see mainsail, apparently something to do with the Nvidia in my laptop.
Tried Ubuntu desktop, pretty much same deal.
I then tried raspberrypi for desktop and looked promising but could not get it to connect.
Finally installed Ubuntu server, that finally got it to connect but I had to control the printer from another room where my windows laptop is.
So I installed Ubuntu mate desktop and if I type in the ip address on the server laptop, I can get mainsail to control the printer from beside it. Thought I’d finally got it sorted but now it won’t connect to mainsail from my windows laptop using the exact same ip address as what is working on the server. Yesterday my ip was, now that doesn’t work but the Linux connects to mainsail on itself with Put the same ip into windows laptop and nothing! Tearing my hair out, been stuffing around with this for a week now and just cannot get a reliable setup.
Any advice on which flavor of Linux I should run to get it to what I want?

This does not look like a Klipper problem, but some messed up Linux and / or network and / or router configuration on your side.

  • All Linux flavors I know (quite some) use DHCP as default to obtain an IP address from your DHCP server (typically your internet router / modem). All your issues are not related to the Linux flavor but to your setup
  • This address usually sticks when you keep using the machines. If not, the router / modem usually offers means to make it static
  • Usually you can also connect via the hostname of the Linux box, e.g. via http://my-strange-linux-installation.local or similar (depends on the general setup and the used router)
  • Also check the trusted_clients: in moonraker.conf. It needs to contain an entry

Generally, and I noticed this once or twice already: Start with a simple setup, i.e. one Klipper instance for one printer and get this up and running.