Klipper stops in middle of print

Basic Information:

Printer Model: CR-10v3
MCU / Printerboard: Creality 4.2.2

Fill out above information and in all cases attach your klippy.log file (use zip to compress it, if too big). Pasting your printer.cfg is not needed
Be sure to check our “Knowledge Base” Category first. Most relevant items, e.g. error messages, are covered there

Describe your issue:

I have a Creality CR10v3 that I upgraded to Klipper a couple months ago. It was working fine until last week and now stops printing mid print. I’m using Orca slicer and have tried multiple STL files but they stop print after the first few layer. Please help! Attached are my log files.

klippy.zip (899.6 KB)
moonraker.log (7.9 KB)

Your log does not contain any error information. Please provoke the error and upload a matching log.

Sorry about that. I’ve uploaded the new logs.
klippy.log (607.7 KB)
moonraker.log (13.0 KB)

See Sudden MCU Shutdown During Print for a current discussion on this subject.

Thank you for following up. So it appears my issue is either the cable or the RPi that I’m using. I’ll try swapping out the USB cable today and if that doesn’t work, I do have another newer RPi that I can use. Could it also be an issue with the power adapter for the RPi? I appreciate your help.

A too weak RPi power supply that is causing a throttleing condition would rather cause a Timer too close error.

Looks like it was just the USB cable. I’ve completed 2 prints so far and everything seems fine. Thank you for help.

1 Like

Can I ask what kind of USB cable you were using that seemed to have caused the problems and what kind you replaced it with?

I’m asking because I’ve never had an issue with USB cables and it’s not like I’ve ever gotten any exotic brands or anything - right now everything I’m running with is from a local dollar store.

It was just a generic USB cable and it had been working for years. I swapped it out with an Anker USB cable.

How long was it and how long is the Anker?

As I’ve said, I’ve never had the issues that other people seem to and I’m curious as to why.

They are each 3 ft tables. Ended up using the old cable to power another USB device last night and it worked fine.

I’ve had this happen before, usually with cables that had seen some things (spent some time floating around the car, used as an everyday charging cable, etc.). They seem to “work fine” because they charge the phone, but the data transfer is flaky because the data lines are much more sensitive to the effects of the degraded connections.


If the data lines are broken, it’s surprising (to me) that the phone doesn’t throw an error - there are a number of different configurations set in the USB standard for how the USB D+ & D- lines are supposed to be set while charging.

I just pulled the below from the datasheet from a chip I’ve worked with in the past to give you an idea of some of the modes (this is before USB C):

I guess in practical terms if the phone (or other device) gets power it takes it, probably at a reduced draw of 250mA/500mA or so if the lines are not set at expected values.

I absolutely share @theophile experience. Have more than one cable (highest bidding stupid Apple Lightning cables) that would still charge but fail to transmit data.

1 Like

I’ve never tested, but I suspect it’s not a matter of the data lines being completely broken, just degraded to the point that data transmission is unreliable. The cable might “look” fine from a continuity standpoint but once data starts getting flung across it at high speeds, some packets don’t survive the journey.

1 Like

I doubt it’s the wire. Probably the connectors of the cable are causing problems. Corrosion (I’m always talking about both sides, cable and the other side (here RPi)). Gold plating on the contacts is gone, mechanical dimensions are off because of usage, etc. Slow degradation of the connectors is probably the cause.

I wanted to also mention that I had put electrical tape on the power pin to stop the RPi from the powering the CR10 when the main is turned off. Is there a better solution than using tape?

You can try this:


or this:

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.