Rename_existing macro

I’m trying to get ACTIVATE_EXTRUDER to call my T0 and T1 macros for support with SuperSlicer. Those macros obviously need to use the original ACTIVATE_EXTRUDER command.

All the macros are here: KlipperConf/IDEX_macros.cfg at master · charlespick/KlipperConf · GitHub

Seems like you need to name your macro something else.

name the renamed macro or the macro I’m making? I need to override the builtin ACTIVATE_EXTRUDER command and my understanding from the config reference is that this is possible with the rename_existing: option but I apparently have no idea how to use it. I saw other people using a .1 suffix to rename the existing macro so I tried that and I’m getting a new error. Didn’t change anything but the name being used for renaming the builtin macro. How am I getting a new error just by changing the lexical reference?

I also faced this trouble and have found no solution in this manner, but there are two possible WR. 1. add t(x) script as toolchange macro in Superslicer. 2. In my case I wrote a GCODE wrapper in Octoprintt.

There is a known issue when overloading some builtin commands - see: Error when overloaded ACTIVATE_EXTRUDER · Issue #3497 · Klipper3d/klipper · GitHub .


1 Like