Setup EBB36 v1.2 connected to Octopus pro

BTT EBB36 V1.1 CanBoot

BTT EBB36 V1.1 Klipper

klippy.log (606.0 KB)

So i got to the end of the ebb36 install, with all of the steps as shown in the github mks monster guide (linked above) modified to suit pinout of ebb36 and octopus pro.

SSH shows:

pi@VCore3:~ $ lsusb
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 005: ID 1d50:606f OpenMoko, Inc. Geschwister Schneider CAN adapter
Bus 001 Device 002: ID 2109:3431 VIA Labs, Inc. Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

pi@VCore3:~ $ ~/klippy-env/bin/python ~/klipper/scripts/ can0
Found canbus_uuid=1b69030e2982, Application: Klipper
Total 1 uuids found

but now
pi@VCore3:~ $ ls /dev/serial/by-id/*
ls: cannot access ‘/dev/serial/by-id/*’: No such file or directory

Is this correct with the canbus bridge in operation?

I have abandoned the ratos install of printer.cfg and include files as not correct for use with the ebb36, but as a noob have never tried to create this from scratch and get mcu unable to connect.

Can anyone help?

Yes, this is correct. This is explained in the Klipper documentation.


Why are you following a guide from competitor to BigTreeTech?

MKS is not apart of BTT or BIQU


You can try to help Julio from now on, I am out.

There isn’t a BTT Octopus guide available that has the correct information - the maz0r GitHub page is the most accurate/correct that I’ve been able to find. There is the “How to Use CAN Toolhead Boards Connected Directly to Octopus” pdf that I can share if you don’t have a copy but I found it overly complex and forces anybody using to work with PuTTy under Windows when it is much easier to use Unix/Linix commands on the Raspberry Pi (or whatever host system you’re using).

If there is a BTT document for the Octopus that explains how to correctly set it up, I haven’t found it.

Now, the EBB Page setup (GitHub - bigtreetech/EBB) is quite good but the Octopus pages (GitHub - bigtreetech/BIGTREETECH-OCTOPUS-V1.0: This is Octopus open source material and GitHub - bigtreetech/BIGTREETECH-OCTOPUS-Pro: This is OCTOPUS Pro open source material) have nothing on CAN.

If you know of something better please share; what you posted above is accurate but requires the reader to be already familiar with the process.

1 Like

This is just a thankyou to the members who contributed in this thread.

My tool head board is running on canbus, with canboot via the btt octopus pro.

I won’t say i enjoyed the experience and definitely need the help of this group.

A special shout out to @mykepredko & @NAPCAL, who explained the issues from opposite ends and in doing so got this noob to s fully operational V Core 3.1.

Thank you


I have flashed Canboot and Klipper according to the descriptions above.

ls USB shows:

Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 008: ID 1d50:606f OpenMoko, Inc. Geschwister Schneider CAN adapter
Bus 001 Device 003: ID 0edc:2050 YJXU502S USB Camera
Bus 001 Device 002: ID 2109:3431 VIA Labs, Inc. Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

running ~/CanBoot/scripts/ -i can0 -q
the first time shows the canbus-id of the octopus:

Resetting all bootloader node IDs...
Checking for canboot nodes...
Detected UUID: de0481df9aa3, Application: Klipper
Query Complete

I have configured the printer.cfg using this id and the console shows everything as usual.

when I issue another command to query the canbus I get an empty result:

Resetting all bootloader node IDs...
Checking for canboot nodes...
Query Complete

and the connection to the mcu gets lost:

ifconfig show can0 up and running :slight_smile:

can0: flags=193<UP,RUNNING,NOARP>  mtu 16
        unspec 00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00  txqueuelen 256  (UNSPEC)
        RX packets 33466  bytes 250084 (244.2 KiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 3531  bytes 22763 (22.2 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

any idea what the cause could be?

I have to repower octopus in order to get the mcu connected

As soon as it connects to Klipper, the basic query will not show anything because it will not try to gain exclusive access to nodes under Klipper’s control.

sudo services klipper stop
Should be issued before a query or updating Klipper firmware.

Complete the CAN bus wiring because one device on the bus has no benefit.

One big difference is:

for octopus PD0/PD1 needs to be set.

now I can repeatedly call can bus query and always get some result.

drove me crazy!

I worked with Michael from Teaching Tech to produce this video guide, it may be of assistance.

PS, I found I needed to use 1Mbit for my comms speeds due to using every single option on my EBB36. :grin:


@mykepredko, @NAPCAL and others, thanks for the info!

@tlmaclennan, do you maintain the latest version of your doc on github or somewhere that folks can acknowledge, reference, track and/or contribute?

Am new to Klipper, so, I appreciate the info you’ve shared here. Is helping me ramp up building out my V1 Engineering MP3DP v4 mashup with some Voron Trident parts/influences. Cheers!


@azab2c I’ve been slowly working on updating the guide and converting it over to host on GitHub.

This is the best format but is taking some time (low priority for me). Many good guides out there but they are fundamentally flawed…uploaded only to Facebook and in PDF / word doc format. That was my biggest issue with my initial guide so I’m working to change that.

1 Like

If you like, I can offer to reflect your guide here in the Knowledge Base as well


Ok, so ebb36 supports usb mode. Flash the alternate usb firmware. So why do we need to deal with canbus at all? Cant i just flash ebb36, plug a usb c into ebb to my usb hub connected to pi? Then i just lsusb and get the serial path for config.

Given that, not sure i understand the role of the usb device with canbus connections. Seems like i would not need it. Is that just for boards that only support canbus?

It is possible to run something like the EBB42 with USB but you will also have to provide 24V power (with at least 2A) separately.

When I work with CAN, I use an integrated cable with twisted pair for the CAN signals and two 20 AWG lines for power - nice easy package to work with.

When setting up your system, I also highly recommend loading in Katapult first so that you can do firmware updates directly from your host.