Severe undextrusion problem

Basic Information:

Printer Model: Ender 3
MCU / Printerboard: Raspberry Pi 3B / SKR Mini E3 V2.0

Describe your issue:


I am facing severe under extrusion issues currently and I have no clue why. It happens on PLA and PETG

I tried calibrating the extruder several times now like this Extruder Calibration | Ellis’ Print Tuning Guide and it does extrude right around 100mm.

I changed the nozzle to new fresh ones, leveled the bed, made new bed meshes and checked Z-Offset. I also changed the whole hotend assembly with fresh parts. I made sure there is nothing clogging the bowden tube. I did not have these issues on Marlin. Only after upgrading to Klipper, they started to appear. However I also tried going back to Marlin to see if these issues persist and they do. So I guess it is hardware related.

Anyone have an idea what I should check? Any help is greatly appreciated

I added some pictures. I printed this cube at 200°C nozzle, 50°C bed, 50mm/s, 0,2mm layer height with Cura 5.3 and 0,4mm nozzle

My Printer

  • Ender 3
  • SKR Mini E3 V2.0
  • Metal Extruder
  • no other big changes (stock hot end, stock motion system)

klippy.log (2.7 MB)

bottom view

top view

Print hotter and slower to rule that out. You didn’t say what material this test print is but if it’s PETG, 200 is definitely not hot enough. Also check to make sure the extruder is properly tensioned and the filament isn’t grinding.

Regarding your rotation distance calibration, you’re not aiming for “right around 100mm,” you want precisely 100.0mm, no more, no less. That said, the photo definitely doesn’t look like consistent underextrusion so even if your rotation distance isn’t quite right, there’s probably still something else going on as well.

Sorry I forgot to mention that this cube is PLA. I tried printing PLA again with 220° and 40mm/s but somehow it came out even worse.

After that I changed the extruder parts and now it works fine again

1 Like

Any chance your slicer is set to 2.85mm filament?

It was set to 1,75mm but that was not the issue. It was the gear on the extruder. Once replaced, everything worked fine again